Bug 823339 - In advanced search when you change the product it takes a really long time to update the component list
In advanced search when you change the product it takes a really long time to...
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Query/Bug List (Show other bugs)
4.2
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: Simon Green
:
: 823341 823402 823519 826669 826839 826878 828646 829951 831696 834155 842004 842266 844887 844890 847628 847738 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-20 20:17 EDT by Simon Baird
Modified: 2014-10-12 18:48 EDT (History)
21 users (show)

See Also:
Fixed In Version: 4.2.2-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-30 19:39:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Simon Baird 2012-05-20 20:17:04 EDT
Even though there are many thousands of components, I don't think it should take more than a couple of seconds.

I timed it at 15 seconds and I think sometimes it takes longer. Fedora/Fedora is a good one to test since it has the most components.

My guess is there is some code in here [1] that is slower than is should be.

[1] https://bugzilla.redhat.com/js/productform.js
Comment 1 Pierre Ossman 2012-05-21 14:18:33 EDT
It also tends to lock up Firefox completely, and trigger it's warning to kill errant scripts.
Comment 2 Jeff Bastian 2012-05-22 12:28:07 EDT
It takes a minimum of 20 seconds on my system (with a Core i7) to load the Fedora component list and Firefox is completely unusable during that time.

I've also had an warning pop-up saying my extensions (e.g., It's All Text) are taking too long to run while waiting for the component list.

Please bring back the "Refresh Components" button from Bugzilla 3.x
Comment 3 Pierre Ossman 2012-05-22 13:05:43 EDT
Preferably the script would just be better at not locking up the browser while it works.

A busy indicator would also be nice.
Comment 4 Simon Green 2012-06-21 01:31:50 EDT
*** Bug 823402 has been marked as a duplicate of this bug. ***
Comment 5 Simon Green 2012-06-21 01:31:58 EDT
*** Bug 826878 has been marked as a duplicate of this bug. ***
Comment 6 Simon Green 2012-06-21 01:33:05 EDT
*** Bug 826839 has been marked as a duplicate of this bug. ***
Comment 7 Simon Green 2012-06-21 01:33:14 EDT
*** Bug 826669 has been marked as a duplicate of this bug. ***
Comment 8 Simon Green 2012-06-21 01:33:23 EDT
*** Bug 834155 has been marked as a duplicate of this bug. ***
Comment 9 Simon Green 2012-06-21 01:41:35 EDT
I've marked a lot of bugs as a duplicate of this one because they will have a common fix.

Because RHBZ have some products that have thousand of components I feel we're going to need to go back to the old style of 'click here to reload the components' when a product or classification is selected.

For those reporting the 'list of X doesn't show valid value' bugs, this will be fixed a side effect on introducing this change.

For browers that have Javascript enabled, the components select box will be changed with a link to reload the component list (which does a page reload). For non Javascript browsers, there will be a permanent button that does the same thing.
Comment 10 Simon Baird 2012-06-24 21:15:25 EDT
I still think that js should be able to finish whatever it's doing in a sensible amount of time.
Comment 13 Simon Green 2012-08-13 20:41:28 EDT
*** Bug 847738 has been marked as a duplicate of this bug. ***
Comment 14 Simon Green 2012-08-13 20:41:37 EDT
*** Bug 847628 has been marked as a duplicate of this bug. ***
Comment 15 Simon Green 2012-08-13 21:07:37 EDT
*** Bug 844887 has been marked as a duplicate of this bug. ***
Comment 16 Simon Green 2012-08-13 21:07:51 EDT
*** Bug 844890 has been marked as a duplicate of this bug. ***
Comment 17 Simon Green 2012-08-13 21:12:34 EDT
*** Bug 842266 has been marked as a duplicate of this bug. ***
Comment 18 Simon Green 2012-08-13 21:12:47 EDT
*** Bug 842004 has been marked as a duplicate of this bug. ***
Comment 19 Simon Green 2012-08-13 21:31:45 EDT
*** Bug 828646 has been marked as a duplicate of this bug. ***
Comment 20 Simon Green 2012-08-13 21:35:39 EDT
*** Bug 823341 has been marked as a duplicate of this bug. ***
Comment 21 Simon Green 2012-08-13 23:58:16 EDT
*** Bug 823519 has been marked as a duplicate of this bug. ***
Comment 23 Simon Green 2012-08-15 23:35:02 EDT
*** Bug 829951 has been marked as a duplicate of this bug. ***
Comment 24 Simon Green 2012-08-16 21:04:40 EDT
*** Bug 831696 has been marked as a duplicate of this bug. ***
Comment 25 wangjing 2012-08-26 21:51:22 EDT
It went back to the old style of 'click here to reload the components' when a product or classification is selected, we can click the refresh button.
Verified.

Note You need to log in before you can comment on or make changes to this bug.