Bug 823510 - 'bugzilla' (python API program) no longer works against bugzilla.redhat.com
'bugzilla' (python API program) no longer works against bugzilla.redhat.com
Status: CLOSED DUPLICATE of bug 823599
Product: Fedora
Classification: Fedora
Component: python-bugzilla (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: BZ42
  Show dependency treegraph
 
Reported: 2012-05-21 08:40 EDT by Richard W.M. Jones
Modified: 2013-01-10 01:47 EST (History)
7 users (show)

See Also:
Fixed In Version: 4.2.1-1.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-06 19:16:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2012-05-21 08:40:05 EDT
Description of problem:

bugzilla queries fail with this server error:

Server error: <Fault -32000: 'Can\'t locate object method "get_fields" via package "Bugzilla" at /loader/0xbee0f00/Bugzilla/Extension/RedHat/WebService/CompatBugzilla.pm line 2319.\n'>

Version-Release number of selected component (if applicable):

4.2 (?) and python-bugzilla-0.6.2-4.fc17.noarch

How reproducible:

100%

Steps to Reproduce:
1. bugzilla query -b 12345
  
Actual results:

error as above

Expected results:

no error, this worked before the upgrade

Additional info:
Comment 1 Richard W.M. Jones 2012-05-21 08:44:32 EDT
Reading around, it seems to be a problem if Red Hat
has custom templates which use the 'get_fields' method.
Apparently simply replacing these with 'fields' should
fix the problem, although I am unable to verify this.
Comment 2 Simon Green 2012-05-21 09:52:54 EDT
(In reply to comment #1)
> Reading around, it seems to be a problem if Red Hat
> has custom templates which use the 'get_fields' method.
> Apparently simply replacing these with 'fields' should
> fix the problem, although I am unable to verify this.

You are correct that fields replaces get_fields, but it is not a drop in replacement (get_fields returned an array of Bugzilla::Field, fields returns a hash with the field name as the key, and the Bugzilla::Field as the value).

This has been fixed in Bugzilla 4.2.1-1.1 which was released a few minutes ago.

  -- simon
Comment 3 Richard W.M. Jones 2012-05-21 10:06:59 EDT
I don't think it's been fixed correctly.  Try:

$ bugzilla query -b 12345,823510
#12345   CLOSED - Bernhard Rosenkraenzer - ps-to-printer.fpi

Whatever bug numbers you try, only one bug is shown.  Whereas
it should show all the bugs listed (and used to -- I have a
bugzilla script that depends on this).
Comment 4 Simon Green 2012-05-21 10:11:55 EDT
I'm reassigning to the python-bugzilla product since it isn't a fault with the Bugzilla code.
Comment 5 Cole Robinson 2012-06-06 19:16:08 EDT

*** This bug has been marked as a duplicate of bug 823599 ***

Note You need to log in before you can comment on or make changes to this bug.