Bug 823599 - python-bugzilla query unusable
python-bugzilla query unusable
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-bugzilla (Show other bugs)
17
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
:
: 823510 829517 (view as bug list)
Depends On:
Blocks: BZ42
  Show dependency treegraph
 
Reported: 2012-05-21 11:48 EDT by Dean Jansa
Modified: 2013-01-10 01:47 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-17 18:21:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dean Jansa 2012-05-21 11:48:18 EDT
Description of problem:

python 'bugzilla' query no longer works post upgrade.
I noted a message from Michal Novotny regarding a patched python-bugzilla:

"Also, there are some changes that broke the the XML-RPC and
python-bugzilla therefore. I'm having having a patched version but not
100% tested yet since there were still some issues and I personally need
the python-bugzilla for patch maintenance scripts however my version of
repository (i.e. including my patch) is available at:

http://git.engineering.redhat.com/?p=users/minovotn/python-bugzilla.git"

I pulled the fix and still can not run any existing script which uses query.


I get the following error:


Traceback (most recent call last):
  File "/usr/bin/bugzilla", line 805, in <module>
    main()
  File "/usr/bin/bugzilla", line 576, in main
    buglist = bz.query(q)
  File "/usr/lib/python2.7/site-packages/bugzilla/base.py", line 530, in query
    r = self._query(query)
  File "/usr/lib/python2.7/site-packages/bugzilla/bugzilla4.py", line 154, in _query
    query['include_fields'] = query['column_list']
KeyError: 'column_list'
Comment 1 Dean Jansa 2012-05-21 11:51:57 EDT
Prior to using the patched version this was the error I was getting:


Server error: <Fault 53: 'value1-0-0 is not a valid parameter for the Bugzilla::Bug::match function.'>

Server error: <Fault 53: 'type4-0-0 is not a valid parameter for the Bugzilla::Bug::match function.'>
Comment 2 Cole Robinson 2012-06-06 19:16:08 EDT
*** Bug 823510 has been marked as a duplicate of this bug. ***
Comment 3 Fedora Update System 2012-06-06 19:18:33 EDT
python-bugzilla-0.7.0-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/python-bugzilla-0.7.0-1.fc17
Comment 4 Cole Robinson 2012-06-07 09:35:24 EDT
*** Bug 829517 has been marked as a duplicate of this bug. ***
Comment 5 Fedora Update System 2012-06-07 19:03:31 EDT
Package python-bugzilla-0.7.0-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-bugzilla-0.7.0-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-9054/python-bugzilla-0.7.0-1.fc17
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2012-06-17 18:21:15 EDT
python-bugzilla-0.7.0-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.