Bug 823525 - Component Description, Assignee and QA Contact don't match the selected Component
Component Description, Assignee and QA Contact don't match the selected Compo...
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Creating/Changing Bugs (Show other bugs)
4.2
Unspecified Unspecified
urgent Severity urgent (vote)
: ---
: ---
Assigned To: Simon Green
: Reopened
: 823849 824071 (view as bug list)
Depends On:
Blocks: BZ42
  Show dependency treegraph
 
Reported: 2012-05-21 09:12 EDT by Jiri Locker
Modified: 2014-10-12 18:48 EDT (History)
10 users (show)

See Also:
Fixed In Version: 4.2.1-1.6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-28 23:45:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Locker 2012-05-21 09:12:26 EDT
Description of problem:
When I select a component the mentioned fields are filled with values that belong to the component that is just after the selected one.

Version-Release number of selected component (if applicable):
4.2

How reproducible:


Steps to Reproduce:
1. go to https://bugzilla.redhat.com/enter_bug.cgi?product=JBoss%20Enterprise%20BRMS%20Platform%205
2. select '3rd Party' component
  
Actual results:
The description is 'Business Rules Engine' which matches the next component in the list. Assignee and QA Contact fields are also pre-filled with wrong values. This happens with all the components and in other projects too.

Expected results:
The description, assignee and QA contact fields should be pre-filled with the correct values for the selected component

Additional info:
Comment 1 Simon Green 2012-05-22 07:56:07 EDT
*** Bug 823849 has been marked as a duplicate of this bug. ***
Comment 2 Simon Green 2012-05-22 08:06:01 EDT
Will be fixed in the next release.

  -- simon
Comment 4 Simon Green 2012-05-22 17:25:30 EDT
This change is now live.
Comment 5 Simon Green 2012-05-22 18:06:14 EDT
*** Bug 824071 has been marked as a duplicate of this bug. ***
Comment 6 Bill Nottingham 2012-05-23 14:59:24 EDT
I had this happen for a bug I filed after the date in comment #4.

See https://bugzilla.redhat.com/show_bug.cgi?id=824454 - it originally got assigned to jmoskovc@redhat.com.
Comment 7 Bill Nottingham 2012-05-24 09:50:06 EDT
See also https://bugzilla.redhat.com/show_bug.cgi?id=824874, assigned to 'petersen@redhat.com' by default.
Comment 8 Simon Green 2012-05-27 23:43:49 EDT
(In reply to comment #6)
> I had this happen for a bug I filed after the date in comment #4.

I cannot seem to reproduce this error any more, at least the same error that this bug originally fixed.

The only thing I can suggest is the user of bug 824454 and bug 824874 loaded the Enter Bug page before this fix went into place, and submitted the bug afterwards (which meant the bug would still have existed when the submitted the bug).

  -- simon
Comment 9 Radek Novacek 2012-05-28 03:41:19 EDT
This bug is still not fixed. I've got new bug few minutes ago, that has wrong assignee and QA contact. It's bug 825664. 

Or it might be separate issue, since I'm getting assigned only kernel bugs from Dell.

Gireesha, can you tell us, how did you entered last couple of bugs (e.g. 825664, 825619, 825610 etc.)
Comment 10 Gireesha 2012-05-28 03:50:57 EDT
(In reply to comment #9)
> This bug is still not fixed. I've got new bug few minutes ago, that has
> wrong assignee and QA contact. It's bug 825664. 

Or it might be separate
> issue, since I'm getting assigned only kernel bugs from Dell.

Gireesha, can
> you tell us, how did you entered last couple of bugs (e.g. 825664, 825619,
> 825610 etc.)
All these are feature requests for RHEL 6.4, looks like Bugzilla tool has a issue, so it's assigned to wrong person, We don't select the assignee field when we file feature/Bug. i think Red Hat can answer this.
Comment 11 Simon Green 2012-05-28 05:28:28 EDT
Gireesha: Did you use the web UI, or make an RPC call? If the web UI, what browser are you using? Is it possible for you to upload the page source of the enter bug page (the one where you enter the bug details)?

If you were using an RPC call, what is the name of the call?

Radek: I cannot replicate the issue. I created bug 825709 from my normal (non-Red Hat) account for RHEL 6's kernel component, and it was assigned to the correct owner / qa contact.

If someone can give me definitive steps on how to reproduce this error, I'll be able to fix it faster. This was definitely a problem before 4.2.1-1.2 was released last week.

  -- simon
Comment 12 Lukáš Petrovický 2012-05-28 05:31:35 EDT
(In reply to comment #11)
> If someone can give me definitive steps on how to reproduce this error, I'll
> be able to fix it faster. This was definitely a problem before 4.2.1-1.2 was
> released last week.

Can the browser cache be a factor here? After all, the functionality is provided by JavaScript...
Comment 13 Simon Green 2012-05-28 05:35:00 EDT
(In reply to comment #12)
> Can the browser cache be a factor here? After all, the functionality is
> provided by JavaScript...

Very unlikely. The error was in the Javascript on the page itself (i.e. not in a separate JS file), and for products that have > 200 components was replaced by AJAX. I'm now wondering if my AJAX is wonky. I tested this on IE 8/Win 7, Firefox 12/F16 and Chrome 19/F16, and they worked correctly.

  -- simon
Comment 14 Petr Pisar 2012-05-28 05:55:37 EDT
I think there is something wrong with mapping internal Bugzilla user identifiers to e-mail addresses.

See history of bug #824205 <https://bugzilla.redhat.com/show_activity.cgi?id=824205>. The bug has always been assigned to ppisar@redhat.com (the component owner), but somehow different assignee has started to be presented in the public interface and the unlucky guy had to reassign the bug report. There is on reassignment from correct to wrong user in the history listing.
Comment 15 Simon Green 2012-05-28 06:09:26 EDT
It seems that using AJAX to set the values isn't working with 100% accuracy. With the next release (4.2.1-1.6) we'll go back to the 3.6 way of assigning the default assignee, qa contact and default CC:es for products with more than 200 components, which will solve this problem (hopefully).

Products with less than 200 components use Javascript (not AJAX) to set these values, so will remain as is.

  -- simon
Comment 17 Simon Green 2012-05-28 23:45:13 EDT
As mentioned in comment 15, we are going back to the old way of doing things when a product has more than 200 components. This should hopefully fix the problem.

  -- simon
Comment 18 Simon Green 2012-05-29 02:30:50 EDT
Red Hat Bugzilla 4.2.1-1.6 was released a few minutes ago.

  -- simon

Note You need to log in before you can comment on or make changes to this bug.