This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 823570 - [abrt] virt-viewer-0.5.2-8.el6: Process /usr/bin/remote-viewer was killed by signal 11 (SIGSEGV)
[abrt] virt-viewer-0.5.2-8.el6: Process /usr/bin/remote-viewer was killed by ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-gtk (Show other bugs)
6.3
i686 Unspecified
low Severity low
: rc
: 6.4
Assigned To: Christophe Fergeau
Desktop QE
abrt_hash:259bf3171f11918fb5ee2b005e1...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-21 10:41 EDT by David Jaša
Modified: 2013-02-21 03:47 EST (History)
14 users (show)

See Also:
Fixed In Version: spice-gtk-0.14-1.el6
Doc Type: Bug Fix
Doc Text:
No documentation needed
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 03:47:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: maps (24.12 KB, text/plain)
2012-05-21 10:41 EDT, David Jaša
no flags Details
File: remote-viewer-segfault.txt (4.50 KB, text/plain)
2012-05-21 10:41 EDT, David Jaša
no flags Details
File: var_log_messages (13.61 KB, text/plain)
2012-05-21 10:41 EDT, David Jaša
no flags Details
File: dso_list (8.93 KB, text/plain)
2012-05-21 10:41 EDT, David Jaša
no flags Details
File: sosreport.tar.xz (902.99 KB, text/plain)
2012-05-21 10:42 EDT, David Jaša
no flags Details
File: backtrace (18.02 KB, text/plain)
2012-05-21 10:42 EDT, David Jaša
no flags Details
File: build_ids (4.20 KB, text/plain)
2012-05-21 10:42 EDT, David Jaša
no flags Details

  None (edit)
Description David Jaša 2012-05-21 10:41:32 EDT
libreport version: 2.0.9
abrt_version:   2.0.8
backtrace_rating: 4
cmdline:        remote-viewer spice://10.34.29.7/?port=3000 --spice-debug
comment:        the bug occured during shutdown of the guest
crash_function: session_inhibit_keyboard_grab_changed
executable:     /usr/bin/remote-viewer
kernel:         2.6.32-262.el6.i686
pid:            7311
pwd:            /home/shadowman
reason:         Process /usr/bin/remote-viewer was killed by signal 11 (SIGSEGV)
time:           Mon 21 May 2012 04:30:21 PM CEST
uid:            500
username:       shadowman
xsession_errors: 

backtrace:      Text file, 18455 bytes
build_ids:      Text file, 4305 bytes
dso_list:       Text file, 9145 bytes
maps:           Text file, 24703 bytes
remote-viewer-segfault.txt: Text file, 4603 bytes
sosreport.tar.xz: Binary file, 924660 bytes
var_log_messages: Text file, 13939 bytes

environ:
:ORBIT_SOCKETDIR=/tmp/orbit-shadowman
:HOSTNAME=dhcp-29-156.brq.redhat.com
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:TERM=xterm
:SHELL=/bin/bash
:XDG_SESSION_COOKIE=ed9276957d1a5bea266863dc0000003d-1337588740.129944-1912617396
:HISTSIZE=1000
:GTK_RC_FILES=/etc/gtk/gtkrc:/home/shadowman/.gtkrc-1.2-gnome2
:WINDOWID=44040195
:QTDIR=/usr/lib/qt-3.3
:QTINC=/usr/lib/qt-3.3/include
:IMSETTINGS_MODULE=none
:USER=shadowman
:LS_COLORS=rs=0:di=01;34:ln=01;36:mh=00:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:mi=01;05;37;41:su=37;41:sg=30;43:ca=30;41:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.lzma=01;31:*.tlz=01;31:*.txz=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.dz=01;31:*.gz=01;31:*.lz=01;31:*.xz=01;31:*.bz2=01;31:*.tbz=01;31:*.tbz2=01;31:*.bz=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.rar=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.svg=01;35:*.svgz=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.flv=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.cgm=01;35:*.emf=01;35:*.axv=01;35:*.anx=01;35:*.ogv=01;35:*.ogx=01;35:*.aac=01;36:*.au=01;36:*.flac=01;36:*.mid=01;36:*.midi=01;36:*.mka=01;36:*.mp3=01;36:*.mpc=01;36:*.ogg=01;36:*.ra=01;36:*.wav=01;36:*.axa=01;36:*.oga=01;36:*.spx=01;36:*.xspf=01;36:
:GNOME_KEYRING_SOCKET=/tmp/keyring-4bdUDY/socket
:SSH_AUTH_SOCK=/tmp/keyring-4bdUDY/socket.ssh
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/3402,unix/unix:/tmp/.ICE-unix/3402
:USERNAME=shadowman
:DESKTOP_SESSION=gnome
:MAIL=/var/spool/mail/shadowman
:PATH=/usr/lib/qt-3.3/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/shadowman/bin
:QT_IM_MODULE=xim
:PWD=/home/shadowman
:XMODIFIERS=@im=none
:GDM_KEYBOARD_LAYOUT=us
:LANG=en_US.utf8
:GDM_LANG=en_US.utf8
:GDMSESSION=gnome
:SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass
:HISTCONTROL=ignoredups
:HOME=/home/shadowman
:SHLVL=2
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:LOGNAME=shadowman
:QTLIB=/usr/lib/qt-3.3/lib
:CVS_RSH=ssh
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-Tiu6Xtavdd,guid=9067a125a6b192618286b54d00000061
:'LESSOPEN=|/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:DISPLAY=:0.0
:G_BROKEN_FILENAMES=1
:XAUTHORITY=/var/run/gdm/auth-for-shadowman-86W2P6/database
:COLORTERM=gnome-terminal
:_=/usr/bin/remote-viewer

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            10485760             unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 29689                processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       29689                29689                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/pts/1
:pos:	0
:flags:	02
:1:/dev/pts/1
:pos:	0
:flags:	02
:2:/dev/pts/1
:pos:	0
:flags:	02
:3:socket:[236681]
:pos:	0
:flags:	04002
:4:pipe:[236683]
:pos:	0
:flags:	00
:5:pipe:[236683]
:pos:	0
:flags:	01
:6:pipe:[236688]
:pos:	0
:flags:	00
:7:pipe:[236688]
:pos:	0
:flags:	01
:8:anon_inode:[timerfd]
:pos:	0
:flags:	04002
:9:socket:[236689]
:pos:	0
:flags:	02
:10:socket:[236690]
:pos:	0
:flags:	04002
Comment 1 David Jaša 2012-05-21 10:41:46 EDT
Created attachment 585833 [details]
File: maps
Comment 2 David Jaša 2012-05-21 10:41:49 EDT
Created attachment 585834 [details]
File: remote-viewer-segfault.txt
Comment 3 David Jaša 2012-05-21 10:41:52 EDT
Created attachment 585835 [details]
File: var_log_messages
Comment 4 David Jaša 2012-05-21 10:41:57 EDT
Created attachment 585836 [details]
File: dso_list
Comment 5 David Jaša 2012-05-21 10:42:04 EDT
Created attachment 585837 [details]
File: sosreport.tar.xz
Comment 6 David Jaša 2012-05-21 10:42:07 EDT
Created attachment 585838 [details]
File: backtrace
Comment 7 David Jaša 2012-05-21 10:42:10 EDT
Created attachment 585839 [details]
File: build_ids
Comment 9 David Jaša 2012-05-27 15:36:51 EDT
Looking at the backtrace, the crash occured when in spice-gtk code.
Comment 10 Marc-Andre Lureau 2012-05-29 08:08:01 EDT
Apparently, we forgot to disconnect the handler.
I sent a proposed patch to ML.

Do you have a reproducer test-case?
Comment 11 David Jaša 2012-05-29 08:19:11 EDT
(In reply to comment #10)
> Apparently, we forgot to disconnect the handler.
> I sent a proposed patch to ML.
> 
> Do you have a reproducer test-case?

Unfortunately not. I often do shutdown the guest without closing client and this was a sole moment when something went wrong.
Comment 12 RHEL Product and Program Management 2012-07-10 04:44:45 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 13 RHEL Product and Program Management 2012-07-10 22:00:30 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 20 errata-xmlrpc 2013-02-21 03:47:38 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0343.html

Note You need to log in before you can comment on or make changes to this bug.