Bug 823586 - Gluster - Backend: Exception on failed Brick Replace
Gluster - Backend: Exception on failed Brick Replace
Status: CLOSED DUPLICATE of bug 823565
Product: oVirt
Classification: Community
Component: ovirt-engine-core (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Bala.FA
Haim
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-21 11:09 EDT by Daniel Paikov
Modified: 2015-11-22 21:57 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-24 05:19:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine.log (2.21 KB, application/x-compressed-tar)
2012-05-21 11:09 EDT, Daniel Paikov
no flags Details

  None (edit)
Description Daniel Paikov 2012-05-21 11:09:57 EDT
Created attachment 585851 [details]
engine.log

* Replace a brick in an existing volume.
* Immediately try to replace another brick in the same volume.
* 2nd replace fails because:
[glusterd-replace-brick.c:304:glusterd_op_stage_replace_brick] 0-: Replace brick is already started for volume
* From command line, the failure looks like this:
[root@localhost vdsm]# /usr/sbin/gluster --mode=script volume replace-brick vol3 10.35.97.158:/export node3:/bbbbb start
replace-brick failed to start
* Instead of failing nicely we are throwing an exception.
Comment 1 Shireesh 2012-05-22 05:38:21 EDT
This is happening because of the same gluster-vdsm issue I mentioned in 

https://bugzilla.redhat.com/823285

Assigning to Bala for resolution.
Comment 2 Bala.FA 2012-05-24 05:19:18 EDT

*** This bug has been marked as a duplicate of bug 823565 ***

Note You need to log in before you can comment on or make changes to this bug.