Bug 823590 - [abrt] iptraf-ng-1.1.2-1.fc17: __GI_raise: Process /usr/sbin/iptraf-ng was killed by signal 6 (SIGABRT)
[abrt] iptraf-ng-1.1.2-1.fc17: __GI_raise: Process /usr/sbin/iptraf-ng was ki...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: iptraf-ng (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nikola Pajkovsky
Fedora Extras Quality Assurance
abrt_hash:f32315dc5388389aa1424ac022a...
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-21 11:12 EDT by admin
Modified: 2014-02-02 17:16 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-05 06:43:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: event_log (812 bytes, text/plain)
2012-05-21 11:12 EDT, admin
no flags Details
File: backtrace (7.10 KB, text/plain)
2012-05-21 11:12 EDT, admin
no flags Details
File: smolt_data (2.78 KB, text/plain)
2012-05-21 11:12 EDT, admin
no flags Details
File: coredump (584.00 KB, text/plain)
2012-05-21 11:13 EDT, admin
no flags Details

  None (edit)
Description admin 2012-05-21 11:12:40 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        iptraf-ng
crash_function: __GI_raise
executable:     /usr/sbin/iptraf-ng
kernel:         3.3.6-3.fc17.x86_64
pid:            32273
pwd:            /home/raistlin
remote_result:  NOTFOUND
time:           Пн. 21 мая 2012 22:02:44
uid:            0
username:       root
var_log_messages: May 21 22:02:44 raistlin abrt[32274]: Saved core dump of pid 32273 (/usr/sbin/iptraf-ng) to /var/spool/abrt/ccpp-2012-05-21-22:02:44-32273 (598016 bytes)

backtrace:      Text file, 7268 bytes
event_log:      Binary file, 812 bytes
smolt_data:     Binary file, 2846 bytes

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/raistlin/3

comment:
:Just run
:

core_backtrace:
:a4ec59d7fc9c453fb4287d7ebc5fcf6579792e65 0x35965 raise libc.so.6 -
:a4ec59d7fc9c453fb4287d7ebc5fcf6579792e65 0x37118 abort libc.so.6 -
:a4ec59d7fc9c453fb4287d7ebc5fcf6579792e65 0x7568b __libc_message libc.so.6 -
:a4ec59d7fc9c453fb4287d7ebc5fcf6579792e65 0x7c80e _int_free libc.so.6 -
:2ecb5412f62a3e7a6c211bec96bef3c114116092 0x4ad7 - [exe] -
:2ecb5412f62a3e7a6c211bec96bef3c114116092 0x3430 - [exe] -

dso_list:
:/usr/lib64/libpanel.so.5.9 ncurses-libs-5.9-4.20120204.fc17.x86_64 (Fedora Project) 1330115453
:/usr/sbin/iptraf-ng iptraf-ng-1.1.2-1.fc17.x86_64 (Fedora Project) 1336212112
:/usr/lib64/libtinfo.so.5.9 ncurses-libs-5.9-4.20120204.fc17.x86_64 (Fedora Project) 1330115453
:/usr/lib64/libgcc_s-4.7.0-20120507.so.1 libgcc-4.7.0-5.fc17.x86_64 (Fedora Project) 1336450152
:/usr/lib64/libc-2.15.so glibc-2.15-37.fc17.x86_64 (Fedora Project) 1336824396
:/usr/lib64/libncurses.so.5.9 ncurses-libs-5.9-4.20120204.fc17.x86_64 (Fedora Project) 1330115453
:/usr/lib64/ld-2.15.so glibc-2.15-37.fc17.x86_64 (Fedora Project) 1336824396
:/usr/lib64/libdl-2.15.so glibc-2.15-37.fc17.x86_64 (Fedora Project) 1336824396

environ:
:XDG_VTNR=1
:KDE_MULTIHEAD=false
:XDG_SESSION_ID=3
:SSH_AGENT_PID=22859
:DM_CONTROL=/var/run/xdmctl
:HOSTNAME=raistlin.hostace.ru
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:XDG_MENU_PREFIX=kde4-
:TERM=xterm
:SHELL=/bin/bash
:XDM_MANAGED=method=classic
:HISTSIZE=1000
:KONSOLE_DBUS_SERVICE=:1.95
:GTK2_RC_FILES=/etc/gtk-2.0/gtkrc:/home/raistlin/.gtkrc-2.0:/home/raistlin/.gtkrc-2.0-kde4:/home/raistlin/.kde/share/config/gtkrc-2.0
:GTK_RC_FILES=/etc/gtk/gtkrc:/home/raistlin/.gtkrc:/home/raistlin/.kde/share/config/gtkrc
:GS_LIB=
:WINDOWID=79691797
:GNOME_KEYRING_CONTROL=/home/raistlin/.cache/keyring-hhoDbi
:QTDIR=/usr/lib64/qt-3.3
:QTINC=/usr/lib64/qt-3.3/include
:SHELL_SESSION_ID=8cf308644d404000be7ae7ccb616306c
:KDE_FULL_SESSION=true
:QT_GRAPHICSSYSTEM_CHECKED=1
:'IMSETTINGS_MODULE=X compose table'
:USER=raistlin
:XCURSOR_SIZE=0
:LS_COLORS=rs=0:di=01;34:ln=01;36:mh=00:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:mi=01;05;37;41:su=37;41:sg=30;43:ca=30;41:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.lzma=01;31:*.tlz=01;31:*.txz=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.dz=01;31:*.gz=01;31:*.lz=01;31:*.xz=01;31:*.bz2=01;31:*.tbz=01;31:*.tbz2=01;31:*.bz=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.war=01;31:*.ear=01;31:*.sar=01;31:*.rar=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.svg=01;35:*.svgz=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.flv=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.cgm=01;35:*.emf=01;35:*.axv=01;35:*.anx=01;35:*.ogv=01;35:*.ogx=01;35:*.aac=01;36:*.au=01;36:*.flac=01;36:*.mid=01;36:*.midi=01;36:*.mka=01;36:*.mp3=01;36:*.mpc=01;36:*.ogg=01;36:*.ra=01;36:*.wav=01;36:*.axa=01;36:*.oga=01;36:*.spx=01;36:*.xspf=01;36:*.pdf=00;33:*.ps=00;33:*.ps.gz=00;33:*.txt=00;33:*.patch=00;33:*.diff=00;33:*.log=00;33:*.tex=00;33:*.xls=00;33:*.xlsx=00;33:*.ppt=00;33:*.pptx=00;33:*.rtf=00;33:*.doc=00;33:*.docx=00;33:*.odt=00;33:*.ods=00;33:*.odp=00;33:*.xml=00;33:*.epub=00;33:*.abw=00;33:*.html=00;33:*.wpd=00;33:
:SSH_AUTH_SOCK=/tmp/ssh-PgtfgyP22708/agent.22708
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/22944,unix/unix:/tmp/.ICE-unix/22944
:PATH=/usr/lib64/qt-3.3/bin:/usr/local/bin:/usr/bin:/bin:/usr/games:/usr/local/sbin:/usr/sbin:/home/raistlin/.local/bin:/home/raistlin/bin
:MAIL=/var/spool/mail/raistlin
:DESKTOP_SESSION=kde-plasma
:QT_IM_MODULE=xim
:PWD=/home/raistlin
:XMODIFIERS=@im=none
:KDE_IS_PRELINKED=1
:GNOME_KEYRING_PID=22706
:LANG=ru_RU.UTF-8
:KDE_SESSION_UID=1000
:KDEDIRS=/usr
:KONSOLE_DBUS_SESSION=/Sessions/1
:SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass
:HISTCONTROL=ignoredups
:SHLVL=4
:XDG_SEAT=seat0
:COLORFGBG=15;0
:HOME=/root
:LANGUAGE=
:KDE_SESSION_VERSION=4
:XCURSOR_THEME=BlueIllusion2_left
:LOGNAME=raistlin
:QTLIB=/usr/lib64/qt-3.3/lib
:CVS_RSH=ssh
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-TniEcL4tK1,guid=3658ddb5e5d8a622723ecaa300004507
:XDG_DATA_DIRS=/usr/share/kde-settings/kde-profile/default/share:/usr/local/share:/usr/share
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:DISPLAY=:0
:XDG_RUNTIME_DIR=/run/user/raistlin
:PROFILEHOME=
:QT_PLUGIN_PATH=/home/raistlin/.kde/lib64/kde4/plugins/:/usr/lib64/kde4/plugins/:/usr/lib/kde4/plugins
:GTK_IM_MODULE=xim
:XAUTHORITY=/root/.xauthWIU8do
:_=/usr/sbin/iptraf-ng

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 15786                processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       15786                15786                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

maps:
:00400000-00429000 r-xp 00000000 fd:02 1329883                            /usr/sbin/iptraf-ng
:00628000-00629000 r--p 00028000 fd:02 1329883                            /usr/sbin/iptraf-ng
:00629000-0062a000 rw-p 00029000 fd:02 1329883                            /usr/sbin/iptraf-ng
:0062a000-0062c000 rw-p 00000000 00:00 0 
:01685000-016c7000 rw-p 00000000 00:00 0                                  [heap]
:322ce00000-322ce03000 r-xp 00000000 fd:02 1366395                        /usr/lib64/libpanel.so.5.9
:322ce03000-322d002000 ---p 00003000 fd:02 1366395                        /usr/lib64/libpanel.so.5.9
:322d002000-322d003000 r--p 00002000 fd:02 1366395                        /usr/lib64/libpanel.so.5.9
:322d003000-322d004000 rw-p 00003000 fd:02 1366395                        /usr/lib64/libpanel.so.5.9
:367ae00000-367ae20000 r-xp 00000000 fd:02 1351343                        /usr/lib64/ld-2.15.so
:367b01f000-367b020000 r--p 0001f000 fd:02 1351343                        /usr/lib64/ld-2.15.so
:367b020000-367b021000 rw-p 00020000 fd:02 1351343                        /usr/lib64/ld-2.15.so
:367b021000-367b022000 rw-p 00000000 00:00 0 
:367b200000-367b3ac000 r-xp 00000000 fd:02 1351344                        /usr/lib64/libc-2.15.so
:367b3ac000-367b5ac000 ---p 001ac000 fd:02 1351344                        /usr/lib64/libc-2.15.so
:367b5ac000-367b5b0000 r--p 001ac000 fd:02 1351344                        /usr/lib64/libc-2.15.so
:367b5b0000-367b5b2000 rw-p 001b0000 fd:02 1351344                        /usr/lib64/libc-2.15.so
:367b5b2000-367b5b7000 rw-p 00000000 00:00 0 
:367be00000-367be03000 r-xp 00000000 fd:02 1351346                        /usr/lib64/libdl-2.15.so
:367be03000-367c002000 ---p 00003000 fd:02 1351346                        /usr/lib64/libdl-2.15.so
:367c002000-367c003000 r--p 00002000 fd:02 1351346                        /usr/lib64/libdl-2.15.so
:367c003000-367c004000 rw-p 00003000 fd:02 1351346                        /usr/lib64/libdl-2.15.so
:367ca00000-367ca15000 r-xp 00000000 fd:02 1351354                        /usr/lib64/libgcc_s-4.7.0-20120507.so.1
:367ca15000-367cc14000 ---p 00015000 fd:02 1351354                        /usr/lib64/libgcc_s-4.7.0-20120507.so.1
:367cc14000-367cc15000 rw-p 00014000 fd:02 1351354                        /usr/lib64/libgcc_s-4.7.0-20120507.so.1
:3688a00000-3688a25000 r-xp 00000000 fd:02 1329078                        /usr/lib64/libtinfo.so.5.9
:3688a25000-3688c24000 ---p 00025000 fd:02 1329078                        /usr/lib64/libtinfo.so.5.9
:3688c24000-3688c28000 r--p 00024000 fd:02 1329078                        /usr/lib64/libtinfo.so.5.9
:3688c28000-3688c29000 rw-p 00028000 fd:02 1329078                        /usr/lib64/libtinfo.so.5.9
:3689e00000-3689e23000 r-xp 00000000 fd:02 1339597                        /usr/lib64/libncurses.so.5.9
:3689e23000-368a022000 ---p 00023000 fd:02 1339597                        /usr/lib64/libncurses.so.5.9
:368a022000-368a023000 r--p 00022000 fd:02 1339597                        /usr/lib64/libncurses.so.5.9
:368a023000-368a024000 rw-p 00023000 fd:02 1339597                        /usr/lib64/libncurses.so.5.9
:7f9faed01000-7f9faed05000 rw-p 00000000 00:00 0 
:7f9faed3a000-7f9faed3c000 rw-p 00000000 00:00 0 
:7fff12c53000-7fff12c74000 rw-p 00000000 00:00 0                          [stack]
:7fff12c93000-7fff12c94000 r-xp 00000000 00:00 0                          [vdso]
:ffffffffff600000-ffffffffff601000 r-xp 00000000 00:00 0                  [vsyscall]

open_fds:
:0:/dev/pts/1
:pos:	0
:flags:	0102002
:1:/dev/pts/1
:pos:	0
:flags:	0102002
:2:/dev/pts/1
:pos:	0
:flags:	0102002
:3:/dev/tty
:pos:	0
:flags:	0104002
Comment 1 admin 2012-05-21 11:12:45 EDT
Created attachment 585852 [details]
File: event_log
Comment 2 admin 2012-05-21 11:12:48 EDT
Created attachment 585853 [details]
File: backtrace
Comment 3 admin 2012-05-21 11:12:50 EDT
Created attachment 585854 [details]
File: smolt_data
Comment 4 admin 2012-05-21 11:13:01 EDT
Created attachment 585855 [details]
File: coredump
Comment 5 Nikola Pajkovsky 2012-05-21 11:52:42 EDT
those two patches should fix your problem. Wait till +- tomorrow or clone git and build your own version.

$ git clone git://git.fedorahosted.org/git/iptraf-ng.git

commit b3eec3f99eba107b2c9298bc44e74eed567b5477
Author: Nikola Pajkovsky <npajkovs@redhat.com>
Date:   Mon May 21 11:57:06 2012 +0200

    winops: fix the off-by-one error
    
    https://bugzilla.redhat.com/show_bug.cgi?id=795868
    
    Reported-by: Petr Holasek <pholasek@redhat.com>
    Reported-by: Ricardo Catalinas Jiménez <jimenezrick@gmail.com>
    Acked-by: Vitezslav Samel <vitezslav@samel.cz>
    Signed-off-by: Samuel Sieb <samuel-rhbugs@sieb.net>
    Signed-off-by: Nikola Pajkovsky <npajkovs@redhat.com>


commit 208c460b3fd15efb1d4dad095be362af789db6f3
Author: Vitezslav Samel <vitezslav@samel.cz>
Date:   Wed May 9 13:17:32 2012 +0200

    packet.c: packet_get() fix
    
    Formerly we used to signalize we don't have any packet by setting
    its length to zero. This has been broken since commit
    "packet.c: define struct pkt_hdr and functions on it", because
    we incorectly zero the length only in the case recvfrom() failed.
    
    Fix this by zeroing in every case and only set it to the right
    value in the case of succesful recvfrom().
    
    Signed-off-by: Vitezslav Samel <vitezslav@samel.cz>
    Signed-off-by: Nikola Pajkovsky <npajkovs@redhat.com>
Comment 6 admin 2012-05-22 03:33:32 EDT
Fixed, tested. All ok.
Comment 7 admin 2012-05-24 11:51:05 EDT
No updates in Fedora. Reopening bug.
Comment 8 Nikola Pajkovsky 2012-05-25 03:24:22 EDT
grab iptraf-ng-1.1.3.1-1 from fedora update testing or wait a little

Note You need to log in before you can comment on or make changes to this bug.