Bug 823695 - Detail editing requires another click to disclose mime-type
Detail editing requires another click to disclose mime-type
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Attachments/Requests (Show other bugs)
4.4
Unspecified Unspecified
medium Severity medium (vote)
: ---
: ---
Assigned To: Matt Tyson
tools-bugs
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-21 18:19 EDT by Brian Lane
Modified: 2014-02-03 20:13 EST (History)
3 users (show)

See Also:
Fixed In Version: 4.4.1013
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-03 20:13:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Lane 2012-05-21 18:19:10 EDT
A common task in bug triage is changing the mime type of mis-identified attachments. In the previous bz you clicked on details, edited it and submitted. Now we need to click on a second details link to expose the mime type editing fields. These fields should be exposed by default.
Comment 2 xuezhi ma 2012-11-19 03:35:40 EST
Verify version: 4.2.4-7 on test server -> PASS

Verify steps:
1. Login bugzilla.
2. Choose one bug and go to its detail page.
3. Add a attachment to this bug.
4. Click details link of this attachment.

Actual result:
All detail information are shown in the page, don't need to click another edit details button.
Comment 3 Brian Lane 2013-12-19 14:02:05 EST
The behavior has changed back to needing another click to open details. I'm not sure which release changed, but it is happening with 4.4.1012-2
Comment 4 Jason McDonald 2013-12-23 22:32:55 EST
I can reproduce this issue:

1. Open https://bugzilla.redhat.com/show_bug.cgi?id=1004727
2. Click the "Details' link to the right of the attachment.
3. Click "Edit Details" at the top of the main panel.
4. Now you can change the mime type.

Note that the pages in steps 3 and 4 are actually the same page -- the Edit Details link just triggers some javascript that makes the extra fields appear (and there's a "Hide" link that removes them again).

Given the date of the previous patch, I'd guess that we managed to lose the patch in the upgrade from BZ 4.2 to 4.4.
Comment 5 Matt Tyson 2014-01-09 21:23:38 EST
It looks like the change was lost during a code sync.
I've added the fix back in.
Comment 7 Simon Green 2014-01-29 18:26:08 EST
So this go committed as part of sprint13.
Comment 8 Jason McDonald 2014-02-03 20:13:36 EST
This change is now live. If there are any issues, do not reopen this bug.
Instead, you should create a new bug and reference this bug.

Note You need to log in before you can comment on or make changes to this bug.