Bug 823758 - p2v client should have largest number restrictions for CPU and Memory settings
p2v client should have largest number restrictions for CPU and Memory settings
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libguestfs (Show other bugs)
7.1
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Richard W.M. Jones
Virtualization Bugs
P2V
:
: 855061 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-22 01:17 EDT by Cui Lei
Modified: 2015-11-19 01:56 EST (History)
9 users (show)

See Also:
Fixed In Version: libguestfs-1.28.1-1.33.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 01:56:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cui Lei 2012-05-22 01:17:55 EDT
Description of problem:
In virt-p2v setting page, p2v client should have largest number restrictions for CPU and Memory settings.
As both convert to KVM and RHEV, there is Virtualization restrictions.
In current p2v client, set the "numbers of CPU" and "Memory(MB)" as 99999999, conversion (include covnerted to KVM and RHEV)could be successful.

1. KVM restrictions:
Maximum VCPUs per guest
Virtualized guests support up to a maximum of 64 virtualized CPUs in Red Hat Enterprise Linux 6.
http://docs.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/6/html/Virtualization_Host_Configuration_and_Guest_Installation_Guide/chap-Virtualization_Host_Configuration_and_Guest_Installation_Guide-Virtualization_Restrictions.html
2. RHEV 3.0:
Guest scalability: Supports up to 64 vCPU and 2TB vRAM per guest
From FEATURE GUIDE of RED HAT ENTERPRISE VIRTUALIZATION 3.0

Version-Release number of selected component (if applicable):
virt-p2v-0.8.6-5.20120502.1.el6.iso
virt-v2v-0.8.7-6.el6.x86_64
libguestfs-1.16.19-1.el6.x86_64
libvirt-0.9.10-20.el6.x86_64
augeas-0.9.0-4.el6.x86_64
febootstrap-3.12-1.el6.x86_64
hivex-1.3.3-4.el6.x86_64
libguestfs-winsupport-1.0-7.el6.x86_64
virtio-win-1.5.1-1.el6.noarch

How reproducible:
Always.

Steps to Reproduce:
1. Load virt-p2v iso.
2. In virt-p2v setting page, both set the "number of CPU" and "Memory(MB)" as 99999999, click convert button

Actual Results:
Conversion could be finished successfully. But start the converted guest failed, error message pop up
"Error starting domain: internal error Process exited while reading console log output: Unsupported number of maxcpus" from virt-manager.
BTW, first check the converted guest in virt-manager, the number of CPU has changed to 57599

Expected results:
Conversion should be refused, and hint the number have exceeded the maximum support number.
Comment 1 RHEL Product and Program Management 2012-12-14 01:50:17 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 3 Richard W.M. Jones 2015-03-12 12:56:01 EDT
It seems like a good idea to limit the guest #vCPUs and
memory to whatever the limits are for RHEL KVM.  As far as
I recall, virt-p2v doesn't do that, but it should be a
trivial change.  Probably take longer to find out what the
limits are supposed to be than to implement it :-)
Comment 5 Richard W.M. Jones 2015-03-12 13:38:19 EDT
*** Bug 855061 has been marked as a duplicate of this bug. ***
Comment 6 Richard W.M. Jones 2015-05-05 10:13:50 EDT
Patches posted:
https://www.redhat.com/archives/libguestfs/2015-May/msg00006.html
Comment 7 Richard W.M. Jones 2015-05-06 13:07:14 EDT
Upstream commits:

1189d5919e4b3edceaa6a58b914ae29123754074
e7833a5eea350ca3579d1f9e6702e116b45572fc
Comment 8 Richard W.M. Jones 2015-05-06 13:10:13 EDT
Ignore comment 7.  The correct commits are:

b1336f26e6a4a643eefd7422e8cd2d4520b1a565
1189d5919e4b3edceaa6a58b914ae29123754074
Comment 10 tingting zheng 2015-06-01 01:36:58 EDT
Tested with:
libguestfs-1.28.1-1.36.el7.x86_64
virt-v2v-1.28.1-1.36.el7.x86_64
livecd-p2v-201505191242.iso

After launch virt-p2v client,when I set cpu largen than 160 and memory larger than 4096000,the below waring will be showed:

Number of virtual CPUs is larger than what is supported for KVM (max: 160).
Memory size is larger than what is supported for KVM (max: 4096000).
If you ignore this warning, conversion can still succeed, but the guest may not work or may not be supported on the target.	

Refer to the above comments,move the bug to VERIFIED.
Comment 12 errata-xmlrpc 2015-11-19 01:56:29 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2183.html

Note You need to log in before you can comment on or make changes to this bug.