Bug 823775 - Cannot add new search to certain group in "Custom Search"
Cannot add new search to certain group in "Custom Search"
Status: CLOSED WONTFIX
Product: Bugzilla
Classification: Community
Component: Query/Bug List (Show other bugs)
4.2
All All
unspecified Severity medium (vote)
: ---
: ---
Assigned To: Simon Green
:
: 832190 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-22 02:57 EDT by Gris Ge
Modified: 2014-10-12 18:48 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-07 20:32:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gris Ge 2012-05-22 02:57:20 EDT
Description of problem:

Please take saved search: http://lacrosse.corp.redhat.com/~fge/hurls/st6ack as example.

I want to add "QA Contact is someone@somewhere.com" to the saved correct search group.

But the web UI didn't provide a add button to it.


Version-Release number of selected component (if applicable):
production system.

How reproducible:
100%

Steps to Reproduce:
1. Open saved search http://lacrosse.corp.redhat.com/~fge/hurls/st6ack
2. Try to add "QA contact is someone@somewhere.com" to save group whether QA contact checked.
3.
  
Actual results:
No way to do so.

Expected results:
Provide add botton beside each search patter group.

Additional info:

I do miss the old days.
Comment 1 Simon Green 2012-06-07 20:32:52 EDT
(In reply to comment #0)
> Description of problem:
> 
> Please take saved search: http://lacrosse.corp.redhat.com/~fge/hurls/st6ack
> as example.
> 
> I want to add "QA Contact is someone@somewhere.com" to the saved correct
> search group.
> 
> But the web UI didn't provide a add button to it.

This is a known issue upstream. Three possible work arounds:

1)
Click 'Edit this search'
Expand the 'Custom search' section of the page.
Change one (or all) of the 'QA Contact' search to 'matches the regular expression', and use a regular expression.

2) Hack the URL. You'll need to add the fields field0-1-5, type0-1-5 and  value0-1-5 to match the field0-1-4, type0-1-4 and value0-1-4 fields (obviously changing value0-1-5 to someone@somewhere.com

3) Do a new query.

> I do miss the old days.

Given the number of bugs with the old query code, I don't :)

  -- simon
Comment 2 Simon Green 2012-06-18 19:51:07 EDT
*** Bug 832190 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.