Bug 823881 - Setup networks- add missing functionality
Setup networks- add missing functionality
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Alona Kaplan
Martin Pavlik
network
:
: 825107 (view as bug list)
Depends On:
Blocks: 709060 830832
  Show dependency treegraph
 
Reported: 2012-05-22 07:22 EDT by Alona Kaplan
Modified: 2016-02-10 14:55 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-17 03:09:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The new design (52.53 KB, image/png)
2012-05-22 07:22 EDT, Alona Kaplan
no flags Details

  None (edit)
Description Alona Kaplan 2012-05-22 07:22:40 EDT
Created attachment 586012 [details]
The new design

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Alona Kaplan 2012-05-22 07:36:51 EDT
- Comment- moved to the top
- Checkboxes- check connectivity with timeout text box.
              save network configuration
- Network outside the rhevm- usages symbol- "?", instead of edit, "x" symbol for delete.
- usages- just the "true" usages are shown.
- tooltip- will contain just description, usages with image and mtu.
- the "edit pencil" should be on the netwroks not on the nics.
- there should be an edit pencil on a bond.
- if the management network is detached, when clicking on "ok" the networks box border will become orange (like standart error) and an error popup will jump.


current bugs- 
- the vm symbol is not enabled even if the vm usage is true).
- the detahc network drag doen't work (a network can be detached just from the popup).
- When opening the form there is strange text in the background. It dissapears when clicking on it.
- The "ok" and "cancel" button are not centralized.
Comment 2 Alona Kaplan 2012-05-22 08:44:28 EDT
- "Check connectivity" should be changed to- "Rollback if no connectivity"
(also in "edit managenemt network" form)
Comment 3 Moti Asayag 2012-05-28 03:56:36 EDT
When performing an action via SetupNetorks, there is a busy windonw.
When the action fails and the response is sent back to the client from backend, that window remains open.

It happens each time for any action via SetupNetorks when the VDSM of the target host is down.
Comment 4 Alona Kaplan 2012-05-28 03:56:45 EDT
*** Bug 825107 has been marked as a duplicate of this bug. ***
Comment 5 Alona Kaplan 2012-06-19 04:49:18 EDT
- the "edit pencil" should be on the netwroks not on the nics.
- there should be an edit pencil on a bond- fixed in commit f74995a75bc289edbddc10997083f7e031126325
Comment 6 Alona Kaplan 2012-06-19 06:44:22 EDT
Checkboxes- check connectivity was added and changed to "Rollback changes if Host loses Connectivity to the Engine"
save network configuration was added- in commit 0c5d7a2d6b28f00de22df788fffd755c5442e17b
Comment 7 Alona Kaplan 2012-06-20 11:15:21 EDT
When editing a network through the SetupNetwork form the network parameters should be saved when attaching the network to another nic
(while the SetupNetwork form is open).

Fixed in commit 6a7bfc24982e8b091d0bc5f4da6f3e0cbc8efe88
Comment 8 lpeer 2012-07-17 03:09:29 EDT
This BZ includes many issues, most of them were fixed and tested by other BZ.
The still open issues -

840746 - missing connectivity time out field 
820504 - Pre defined network on host should be reflected in the UI

Note You need to log in before you can comment on or make changes to this bug.