Bug 825107 - [RHEVM] [webadmin] [Setup Host Networks] cannot edit VLAN properties via Setup Networks Dialog
[RHEVM] [webadmin] [Setup Host Networks] cannot edit VLAN properties via Setu...
Status: CLOSED DUPLICATE of bug 823881
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: lpeer
Yaniv Kaul
Network
: Regression
Depends On:
Blocks: 709060 830832
  Show dependency treegraph
 
Reported: 2012-05-25 02:56 EDT by Martin Pavlik
Modified: 2015-09-22 09 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-28 03:56:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot 1 (144.72 KB, image/png)
2012-05-25 02:58 EDT, Martin Pavlik
no flags Details
screenshot 2 (136.54 KB, image/png)
2012-05-25 02:58 EDT, Martin Pavlik
no flags Details

  None (edit)
Description Martin Pavlik 2012-05-25 02:56:06 EDT
Description of problem:
It is not possible to edit VLAN properties via Setup Networks Dialog

Version-Release number of selected component (if applicable):
oVirt Enterprise Virtualization Engine Manager Version: 3.1.0_0001-11.el6ev 

How reproducible:
100%

Steps to Reproduce:

Have some VLANs in cluster
1) Hosts -> your host -> free NIC -> add/edit -> pick VLAN -> choose Boot Protocol: Static -> fill in IP and MASK (say 10.10.10.10/255.255.255.0)
2) if you go Hosts -> your host -> same NIC as in step 1 -> add/edit -> pick VLAN (different than in step1) -> choose Boot Protocol: Static -> fill in IP and MASK (say 11.11.11.11/255.255.255.0)

Now you have host interface with 2 different VLANs, each VLAN has its own IP (screenshot 1)

In present design it is not possible to achieve this state via Setup Host Networks dialog, since you can edit only properties of host NIC not the VLAN/s attached to it. (see screenshot 2)

  
Actual results:
It is not possible to edit VLAN properties via Setup Networks Dialog

Expected results:
It is should be possible to edit VLAN properties via Setup Networks Dialog


Additional info:
Comment 1 Martin Pavlik 2012-05-25 02:58:13 EDT
Created attachment 586782 [details]
screenshot 1
Comment 2 Martin Pavlik 2012-05-25 02:58:31 EDT
Created attachment 586783 [details]
screenshot 2
Comment 3 Alona Kaplan 2012-05-28 03:56:45 EDT

*** This bug has been marked as a duplicate of bug 823881 ***

Note You need to log in before you can comment on or make changes to this bug.