Bug 823899 - RFE: Add tui screen to report plugin information
RFE: Add tui screen to report plugin information
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Guohua Ouyang
Virtualization Bugs
: FutureFeature
Depends On: 823751
Blocks: 816255 823651 839774
  Show dependency treegraph
 
Reported: 2012-05-22 08:21 EDT by Mike Burns
Modified: 2016-04-26 09:42 EDT (History)
11 users (show)

See Also:
Fixed In Version: ovirt-node-2.5.0-9.el6
Doc Type: Enhancement
Doc Text:
A basic plugin detail popup page has been created to report plugin information. This page will show plugin information such as base rpm name, Date Installed, version, list of dependent RPMs installed and the list of files modified.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-28 11:34:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Burns 2012-05-22 08:21:37 EDT
Description of problem:
A separate TUI screen for reporting plugin information needs to be added.  Using details from the files add in bug 823751, a list of all plugins installed with some metadata should be presented.  

Optionally, if possible, choosing a plugin from the list should pop-up a screen that lists the files and/or rpms changed.  

High level idea (feel free to change if you have a better idea)
(assume storage_driver is highlighted)

Plugins Installed

Please select a driver for details.  Hit Enter for additional details

storage_driver
network_driver
plugin3
plugin4


Details for storage_driver
RPM:  storage_driver.rpm
Date Installed:  2012-05-21
Version:  1.2.3-4


------------------------------------

Secondary screen will show base rpm name, Date Installed, Version, list of dependent rpms installed, and list of files modified.
Comment 1 RHEL Product and Program Management 2012-07-10 04:21:53 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 2 RHEL Product and Program Management 2012-07-10 21:49:42 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 5 Joey Boggs 2012-07-26 14:08:01 EDT
http://gerrit.ovirt.org/#/c/6556/
Comment 12 errata-xmlrpc 2013-02-28 11:34:03 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0556.html

Note You need to log in before you can comment on or make changes to this bug.