Bug 824096 - SELinux is preventing /usr/lib/xulrunner-2/plugin-container from 'create' accesses on the file icass3.rng.
SELinux is preventing /usr/lib/xulrunner-2/plugin-container from 'create' acc...
Status: CLOSED DUPLICATE of bug 824099
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:c28c4115360cf3f41c7d784182a...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-22 13:34 EDT by Mikhail
Modified: 2012-05-23 10:34 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-23 10:34:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mikhail 2012-05-22 13:34:46 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.3.6-3.fc17.i686.PAE
time:           Вт. 22 мая 2012 23:34:33

description:
:SELinux is preventing /usr/lib/xulrunner-2/plugin-container from 'create' accesses on the file icass3.rng.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that plugin-container should be allowed create access on the icass3.rng file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep plugin-containe /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c
:                              0.c1023
:Target Context                unconfined_u:object_r:user_home_t:s0
:Target Objects                icass3.rng [ file ]
:Source                        plugin-containe
:Source Path                   /usr/lib/xulrunner-2/plugin-container
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           ICAClient-12.1.0-0.i386
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-125.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.6-3.fc17.i686.PAE #1 SMP Wed May 16
:                              22:01:11 UTC 2012 i686 i686
:Alert Count                   4
:First Seen                    Вт. 22 мая 2012 23:32:48
:Last Seen                     Вт. 22 мая 2012 23:33:15
:Local ID                      958da820-663c-421b-b714-2d0ad1e92576
:
:Raw Audit Messages
:type=AVC msg=audit(1337707995.234:82): avc:  denied  { create } for  pid=7833 comm="wfica" name="icass3.rng" scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1337707995.234:82): arch=i386 syscall=open per=400000 success=no exit=EACCES a0=b72fb7a0 a1=240 a2=1b6 a3=b6901408 items=0 ppid=7202 pid=7833 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 tty=(none) ses=2 comm=wfica exe=/opt/Citrix/ICAClient/wfica subj=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 key=(null)
:
:Hash: plugin-containe,mozilla_plugin_t,user_home_t,file,create
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Miroslav Grepl 2012-05-23 10:34:01 EDT

*** This bug has been marked as a duplicate of bug 824099 ***

Note You need to log in before you can comment on or make changes to this bug.