Bug 824099 - SELinux is preventing /opt/Citrix/ICAClient/wfica from 'write' accesses on the file /home/mikhail/.ICAClient/CtxFlashCache/CacheFile.cache.
SELinux is preventing /opt/Citrix/ICAClient/wfica from 'write' accesses on th...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:2e0bc1cab9e72d8ef6fe4d98371...
:
: 824095 824096 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-22 13:36 EDT by Mikhail
Modified: 2012-06-03 19:31 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-03 19:31:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mikhail 2012-05-22 13:36:17 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.3.6-3.fc17.i686.PAE
time:           Вт. 22 мая 2012 23:36:03

description:
:SELinux is preventing /opt/Citrix/ICAClient/wfica from 'write' accesses on the file /home/mikhail/.ICAClient/CtxFlashCache/CacheFile.cache.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that wfica should be allowed write access on the CacheFile.cache file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep wfica /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c
:                              0.c1023
:Target Context                unconfined_u:object_r:user_home_t:s0
:Target Objects                /home/mikhail/.ICAClient/CtxFlashCache/CacheFile.c
:                              ache [ file ]
:Source                        wfica
:Source Path                   /opt/Citrix/ICAClient/wfica
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           ICAClient-12.1.0-0.i386
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-125.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.6-3.fc17.i686.PAE #1 SMP Wed May 16
:                              22:01:11 UTC 2012 i686 i686
:Alert Count                   3
:First Seen                    Вт. 22 мая 2012 23:35:23
:Last Seen                     Вт. 22 мая 2012 23:35:23
:Local ID                      a248a1c0-b37c-48c5-b40e-aa74445fa30c
:
:Raw Audit Messages
:type=AVC msg=audit(1337708123.245:95): avc:  denied  { write } for  pid=7828 comm="wfica" name="CacheFile.cache" dev="sdb1" ino=80741964 scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1337708123.245:95): arch=i386 syscall=open per=400000 success=no exit=EACCES a0=8ebc3d4 a1=8242 a2=1b6 a3=8eb6250 items=0 ppid=7202 pid=7828 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 tty=(none) ses=2 comm=wfica exe=/opt/Citrix/ICAClient/wfica subj=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 key=(null)
:
:Hash: wfica,mozilla_plugin_t,user_home_t,file,write
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Miroslav Grepl 2012-05-23 10:34:01 EDT
*** Bug 824096 has been marked as a duplicate of this bug. ***
Comment 2 Miroslav Grepl 2012-05-23 10:34:07 EDT
*** Bug 824095 has been marked as a duplicate of this bug. ***
Comment 3 Daniel Walsh 2012-05-24 10:39:48 EDT
What is wfica?

chcon -t mozilla_home_t -R /home/mikhail/.ICAClient

Will fix the problem for now.
Comment 4 Mikhail 2012-05-24 10:46:33 EDT
wfica is Citrix Reciever client http://www.citrix.com/English/ss/downloads/details.asp?downloadId=2323812&productId=1689163
which also installed as mozilla plugin for MIME types:	
MIME type application/x-ica File extensions .ica
folder ".ICAClient" seems used for storing configs and caching.
Comment 5 Daniel Walsh 2012-05-24 11:08:22 EDT
Fixed in selinux-policy-3.10.0-127.fc17
Comment 6 Fedora Update System 2012-05-31 02:27:12 EDT
selinux-policy-3.10.0-128.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/selinux-policy-3.10.0-128.fc17
Comment 7 Fedora Update System 2012-06-01 13:09:11 EDT
Package selinux-policy-3.10.0-128.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.10.0-128.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-8720/selinux-policy-3.10.0-128.fc17
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2012-06-03 19:31:39 EDT
selinux-policy-3.10.0-128.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.