Bug 82429 - Unhandled exception during installation of Red Hat 8.0
Unhandled exception during installation of Red Hat 8.0
Status: CLOSED DUPLICATE of bug 75008
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-21 20:25 EST by William Johnsen
Modified: 2007-04-18 12:50 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:51:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Traceback file of unhandled exception (667.74 KB, text/plain)
2003-01-21 20:28 EST, William Johnsen
no flags Details

  None (edit)
Description William Johnsen 2003-01-21 20:25:49 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0.2)
Gecko/20021120 Netscape/7.01

Description of problem:
During installation, after entering the root password and moving onto the next
task, a little window pops up about loading (or reading) packages. Soon
thereafter, another larger window pops up with an unhandled exception. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Regardless of the steps I take or the installation type (text or graphical,
personal or server)

Actual Results:  Traceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 632, in nextClicked
    self.dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 150, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 215, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/packages.py", line 120, in readPackages
    id.comps = method.readComps(id.hdList)
  File "/usr/lib/anaconda/installmethod.py", line 60, in readComps
    return self.readCompsViaMethod(hdlist)
  File "/usr/lib/anaconda/image.py", line 33, in readCompsViaMethod
    return ComponentSet(fname, hdlist)
  File "/usr/lib/anaconda/comps.py", line 1013, in __init__
    self.readCompsFile(file, self.packages)
  File "/usr/lib/anaconda/comps.py", line 712, in readCompsFile
    self.compsxml = rhpl.comps.Comps(file)
  File "/usr/lib/python2.2/site-packages/rhpl/comps.py", line 297, in __init__
    self.load (filename)
  File "/usr/lib/python2.2/site-packages/rhpl/comps.py", line 304, in load
    doc = libxml2.parseMemory(file, len(file))
  File "/usr/lib/python2.2/site-packages/libxml2.py", line 717, in parseMemory
    if ret == None:raise parserError('xmlParseMemory() failed')
parserError: xmlParseMemory() failed

Additional info:

I saved traceback if needed. Only the top of the traceback file was entered here
since the bug report form fails to accept 0.6 MB or text.
Comment 1 William Johnsen 2003-01-21 20:28:15 EST
Created attachment 89498 [details]
Traceback file of unhandled exception
Comment 2 Jeremy Katz 2003-01-22 00:55:09 EST
Could you please verify your media following the instructions at
http://rhlinux.redhat.com/anaconda/mediacheck.html?
Comment 3 William Johnsen 2003-01-22 09:22:16 EST
Media was verified on installation machine before initial installation. After
exception occurred, media was verified 2 more times. All 3 CDs were verified.
Comment 4 William Johnsen 2003-01-22 09:24:30 EST
Also, used the iso file checker (md5) to ensure proper key.
Comment 5 William Johnsen 2003-01-24 15:52:27 EST
Installed RedHat v7.3 last night without issue. Tried to install v8.0 over v7.3
with the upgrade option instead of the full installtion. When the "reading
packages" window popped up, same error occurred.
Comment 6 William Johnsen 2003-01-27 01:43:35 EST
Thought it might be helpful for you to know that I created, verified, and
installed v7.3 media in precisely the same manner that I did with v8.0 - using
iso images, verifying the media key with md5, booted and installed from cd-rom.
v8.0 had an extra step to verify the media after boot just prior to
installation.  All defaults selected, then location, time zone, and packages
altered post install success.
Comment 7 Michael Fulbright 2003-01-30 15:45:39 EST
This error is the result of a read error from the media, causing the parser to fail.

If you purchased this install media from Red Hat you can get replacement media.

*** This bug has been marked as a duplicate of 75008 ***
Comment 8 William Johnsen 2003-02-03 01:47:23 EST
Successful attempt to install this media on different computer. No Unhandled
Exception occurred where indicated.
Comment 9 Michael Fulbright 2003-02-03 14:16:45 EST

*** This bug has been marked as a duplicate of 75008 ***
Comment 10 Red Hat Bugzilla 2006-02-21 13:51:18 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.