Bug 824432 - [RHEVM] [backend] [Setup Host Networks] cannot add static IP to VLAN
Summary: [RHEVM] [backend] [Setup Host Networks] cannot add static IP to VLAN
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal   
(Show other bugs)
Version: 3.1.0
Hardware: x86_64
OS: Linux
urgent
urgent
Target Milestone: ---
: ---
Assignee: Alona Kaplan
QA Contact: Martin Pavlik
URL:
Whiteboard: network
Keywords:
: 839160 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-05-23 13:01 UTC by Martin Pavlik
Modified: 2016-02-10 19:52 UTC (History)
10 users (show)

Fixed In Version: si12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 20:02:05 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vdsm.log + engine.log (11.17 KB, application/x-gzip)
2012-05-23 13:01 UTC, Martin Pavlik
no flags Details

Description Martin Pavlik 2012-05-23 13:01:35 UTC
Created attachment 586341 [details]
vdsm.log + engine.log

Description of problem:
cannot add static IP to VLAN

it seems that IP is not handed over by webadmin, in following line in VDSM it is visible that no BOOTPROTO or IP is sent for VLAN_2222, despite the fact it was filled in GUI

Thread-4001::DEBUG::2012-05-23 14:45:28,877::BindingXMLRPC::864::vds::(wrapper) client [10.34.63.65]::call setupNetworks with ({'rhevm': {'nic': 'em1', 'BOOTPROTO': 'dhcp', 'bridged': 'true'}, 'VLAN_2222': {'nic': 'p1p1', 'vlan': '2222', 'bridged': 'true'}, 'NET1': {'nic': 'em2', 'netmask': '255.255.255.0', 'ipaddr': '10.34.67.5', 'gateway': '0.0.0.0', 'bridged': 'true'}}, {'bond4': {'remove': 'true'}, 'bond0': {'remove': 'true'}, 'bond1': {'remove': 'true'}, 'bond2': {'remove': 'true'}, 'bond3': {'remove': 'true'}}, {'connectivityCheck': 'true', 'connectivityTimeout': '60000'}) {} flowID [42dea5c1]


Version-Release number of selected component (if applicable):
oVirt Enterprise Virtualization Engine Manager Version: 3.1.0_0001-11.el6ev 

How reproducible:
100%

Steps to Reproduce:
1.create logical network with VLAN tag
2. host -> your host -> network interfaces -> Setup Host Networks
  a) drag VLAN created in step1 to some free NIC
  b) click pecil icon on the NIC 
  c) choose Boot Protocol: static
  d) fill in valid IP and netmask
  c) click OK
3. click OK

  
Actual results:
static IP is NOT assigned to interface, VLAN is assigned to interface

Expected results:
static IP is assigned to interface, VLAN is assigned to interface

Additional info:

Comment 1 lpeer 2012-07-17 07:26:24 UTC
*** Bug 839160 has been marked as a duplicate of this bug. ***

Comment 2 lpeer 2012-07-17 07:26:48 UTC
When fixing this bug we should also make sure this bug also works on top of BOND

Comment 3 lpeer 2012-07-17 07:27:56 UTC
Alona looked at this BZ and looks like a backend issue

Comment 5 Moti Asayag 2012-07-17 10:47:11 UTC
The boot protocol, static ip and network mask were supplied from webadmin on the device interface rather on the vlan-interface (e.g. on ethX raher on ethX.vlanTag).

Comment 6 lpeer 2012-07-17 10:56:58 UTC
please note that this bug applies only for bridged networks.
For bridgeless network we have an open bug on vdsm - 834205

Comment 7 Alona Kaplan 2012-07-17 12:19:30 UTC
fixed in commit 74b13500e45b1a1766b1a4e88d33da950acd35b4


Note You need to log in before you can comment on or make changes to this bug.