Bug 82444 - vmware and vmware-console crash on X
vmware and vmware-console crash on X
Status: CLOSED DUPLICATE of bug 82551
Product: Red Hat Public Beta
Classification: Retired
Component: XFree86 (Show other bugs)
phoebe
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-22 01:59 EST by Michael Loeblich
Modified: 2007-04-18 12:50 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-23 09:54:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Loeblich 2003-01-22 01:59:28 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030115

Description of problem:
Regardless of Gnome or KDE programs vmware and vmware-console
(actual Build 2129) crashes shortly after start in userspace
with following output (or similar):

XIO:  fatal IO error 0 (Success) on X server ":0.0"
      after 2418 requests (2417 known processed) with 13 events remaining.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. starting Gnome
2. starting Console Window
3. starting vmware (or vmware-console)
4. vmware window appears and after some input or immediately crashes
    

Additional info:
Comment 1 Warren Togami 2003-01-23 05:29:21 EST
What happens if you run VMWare with LD_ASSUME_KERNEL=2.2.5?
I don't know the command to start VMWare, but this is an example:

(Running a program with NPTL)
#foo
(Running a program with old threading model)
#LD_ASSUME_KERNEL=2.2.5 foo
Comment 2 Mike A. Harris 2003-01-23 05:45:32 EST

*** This bug has been marked as a duplicate of 82551 ***
Comment 3 Michael Loeblich 2003-01-23 07:02:36 EST
[ml@gateway ml]$ LD_ASSUME_KERNEL=2.2.5 vmware
XIO:  fatal IO error 0 (Success) on X server ":0.0"
      after 3113 requests (3112 known processed) with 8 events remaining.
:-(
Comment 4 Mike A. Harris 2003-01-23 07:12:48 EST
VMware Inc. does not support Red Hat Linux 8.0, nor Red Hat Linux beta
releases.  Red Hat also does not support Red Hat Linux systems which
are running VMware, nor installation into a VMware virtual machine.

While it is unsupported by us, we do hope that it work, however we are
unable to provide technical support or bug tracking facilities for 3rd
party software.  You might find one of VMware's technical forums to be
more appropriate for this matter perhaps.

http://www.vmware.com

Hope this helps.
Comment 5 Michael Loeblich 2003-01-23 09:54:20 EST
from news://news.vmware.com/vmware.for-linux.experimental
 
Thread: rawhide glibc makes vmware crash -- Ideas?

> > latest glibc which works is 2.3.1-16. 2.3.1-30 is broken, and problem
> > comes from the NPTL library - so maybe it is not that trivial to fix :-(
> 
> Not sure where you are getting this information from.  Do you have
> experimental knowledge that -16 worked and -17 doesn't?  What makes you
> think NPTL has something to do with it? (wasn't NPTL included in the
> earlier 2.3.1 releases as well?)

I tried it... Problem is that both VMware and glibc provide errno variable.
In the past (before NPTL) errno was just weak symbol, and so everyone
used errno from VMware. But NPTL change, except other, also changed errno
to be normal strong symbol - and so there are two errnos in the program,
and some code uses one errno, and some code another...

---- cut ----
ml: so I think that ins't a X Problem so closing this bug. Thx.

Note You need to log in before you can comment on or make changes to this bug.