Bug 82551 - VMware and the vmware_drv.o video driver are not supported by Red Hat Linux
VMware and the vmware_drv.o video driver are not supported by Red Hat Linux
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86 (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
: 82444 92200 (view as bug list)
Depends On:
Blocks: 103547
  Show dependency treegraph
 
Reported: 2003-01-23 05:36 EST by Mike A. Harris
Modified: 2013-01-14 09:54 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-23 05:45:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike A. Harris 2003-01-23 05:36:52 EST
This bug has been entered into bugzilla as a "tracker" bug, to be used
to close duplicate bug reports against that are reported by people using
VMware and similar types of software with Red Hat Linux.

While we hope that Red Hat Linux works with VMware, and other such
software, we do not officially support Red Hat Linux running inside
a VMware virtual machine, Virtual PC, User Mode Linux, or any other
emulated or simulated environment, open or closed source.  These
environments, are considered to be alternative architectures for the
purposes of installing an OS into, and are not considered to be a
real supported x86 hardware platform.

We also do not officially support systems which have had any form of
3rd party kernel module inserted into the running kernel since boot
time - even if the module has been subsequently unloaded.  Once a kernel
module has been loaded into the running kernel, it has the potential
to manipulate all internal kernel data structures, and modify arbitrary
memory, either intentionally, or unintentionally due to a bug of some
kind.

VMware and other similar software typically include and require a special
kernel module to be loaded in order for them to function correctly.  These
modules, as stated above, are not supported by Red Hat, and once a user
has loaded them, their system is unsupported unless they can reproduce
any problems they experience after a fresh boot of the OS, without loading
any non-Red Hat supplied kernel modules.

Red Hat does not support any system which is using kernel modules that
did not ship with the distribution or as an erratum update.  We simply
receive too many bug reports from users using such systems, and we
are unable to support such setups.

Some users have also asked about the VMware XFree86 video driver named
"vmware_drv.o".  In the past, we did provide the vmware_drv.o driver
at one point, however we have received far too may bug reports, and
user technical support queries, etc. from people, many of whom expected
that since Red Hat shipped the driver in Red Hat Linux, then we were
under some obligation to offer support for it.

Since we can not, and do not support it, it was decided to remove
the driver from the distribution.  Users who require the vmware_drv.o
XFree86 driver however, you may obtain it from www.vmware.com or compile
it themselves from XFree86 source code, however as mentioned above,
this is totally unsupported by Red Hat.

If you encounter problems with the distribution under VMware or similar
environments, or while using any proprietary or other 3rd party kernel
modules, please ensure that the bug/problem exists also under Red Hat
Linux running natively on a real processor without VMware being used
and/or loaded before reporting any software problems.

In closing, while we do not support VMware and similar environments,
and do not do official distribution tests with it, we do hope that the
distribution works well nonetheless in those types of environments, and
when possible, we try to look into any reasonable bug report and make
things play as nicely as possible as time permits.

There is currently no intention to include the XFree86 vmware driver
in the distribution, nor to provide any type of support for VMware and
other similar types of virtual OS/Hardware platforms.
Comment 1 Mike A. Harris 2003-01-23 05:45:10 EST
Closing report as NOTABUG, as problems that occur while using the operating
system in an unsupported manner, which are not reproduceable otherwise, are
not considered Red Hat Linux bugs.

If you have a bug report which is closed as a duplicate of this report, please
report it to the vendor of the product you are using, or to the upstream
developers whom are responsible for maintaining the software you are using.
Comment 2 Mike A. Harris 2003-01-23 05:45:35 EST
*** Bug 82444 has been marked as a duplicate of this bug. ***
Comment 3 Mike A. Harris 2003-05-16 02:39:06 EDT
*** Bug 72153 has been marked as a duplicate of this bug. ***
Comment 4 Mike A. Harris 2003-06-04 05:26:30 EDT
*** Bug 92200 has been marked as a duplicate of this bug. ***
Comment 6 Ademar Reis 2013-01-10 16:34:56 EST
Removing the alias because it's too generic (messes up with simple searches). Since this was closed as NOTABUG, I assume it's no big deal.

Note You need to log in before you can comment on or make changes to this bug.