Bug 824497 - [RHEVM] [backend] it is possible to remove logical network from host interface while running VM is attached
[RHEVM] [backend] it is possible to remove logical network from host interfac...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
x86_64 Linux
high Severity medium
: ---
: ---
Assigned To: Moti Asayag
Martin Pavlik
network
:
: 840378 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-23 11:32 EDT by Martin Pavlik
Modified: 2016-02-10 14:47 EST (History)
10 users (show)

See Also:
Fixed In Version: si17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vdsm.log + engine.log (21.78 KB, application/x-gzip)
2012-05-23 11:33 EDT, Martin Pavlik
no flags Details
logs2 (731.76 KB, application/x-gzip)
2012-08-16 05:45 EDT, Martin Pavlik
no flags Details

  None (edit)
Description Martin Pavlik 2012-05-23 11:32:59 EDT
Description of problem:
it is possible to remove logical network from host interface while running VM is attached

Version-Release number of selected component (if applicable):
oVirt Enterprise Virtualization Engine Manager Version: 3.1.0_0001-11.el6ev 

How reproducible:
100%

Steps to Reproduce:
1. crate logical network and attach it to host NIC
2. create virtual machine and attach it to logical network created in step 1
3. start VM
4. go to hosts -> your host -> Network Interfaces -> pick your interface -> click detach
    a) check Save Network Configuration
    b) click OK

Actual results:
network is detached from host while VM attached to network is running

Expected results:
network should be not detached, appropriate error message should be displayed 

Additional info:
Comment 1 Martin Pavlik 2012-05-23 11:33:56 EDT
Created attachment 586385 [details]
vdsm.log + engine.log
Comment 2 lpeer 2012-07-16 04:02:07 EDT
*** Bug 840378 has been marked as a duplicate of this bug. ***
Comment 3 Moti Asayag 2012-08-12 17:22:54 EDT
A proposed patch:

http://gerrit.ovirt.org/#/c/7107/
Comment 6 Martin Pavlik 2012-08-16 05:44:37 EDT
It does not work on SI14 it is still possible to remove host network which is attached to running VM. Logs are attached as logs2.

Versions:
libvirt-0.9.10-21.el6_3.3.x86_64
qemu-img-rhev-0.12.1.2-2.298.el6_3.x86_64
vdsm-4.9.6-28.0.el6_3.x86_64

  
Thread-3732::DEBUG::2012-08-16 11:33:27,390::BindingXMLRPC::864::vds::(wrapper) client [10.34.63.65]::call setupNetworks with ({'NET3': {'remove': 'true'}}, {}, {'connectivityCheck': 'true', 'connectivityTimeout': 120}) {} flowID [595a8884]
Comment 7 Martin Pavlik 2012-08-16 05:45:05 EDT
Created attachment 604860 [details]
logs2
Comment 12 Moti Asayag 2012-08-28 08:15:30 EDT
The suggest patch denies removal of a used network by SetupNetworks:

http://gerrit.ovirt.org/#/c/7518/

Note You need to log in before you can comment on or make changes to this bug.