Bug 840378 - Can detach network from host while the network used by running VM
Can detach network from host while the network used by running VM
Status: CLOSED DUPLICATE of bug 824497
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: vdsm (Show other bugs)
6.3
x86_64 Linux
urgent Severity unspecified
: rc
: ---
Assigned To: Dan Kenigsberg
Haim
network
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-16 03:22 EDT by Meni Yakove
Modified: 2014-01-12 19:53 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-16 04:02:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vdsm.log (1.75 MB, application/octet-stream)
2012-07-16 03:22 EDT, Meni Yakove
no flags Details

  None (edit)
Description Meni Yakove 2012-07-16 03:22:25 EDT
Created attachment 598384 [details]
vdsm.log

Description of problem:
Can detach network that assign to VM while the VM running. 

Version-Release number of selected component (if applicable):
vdsm-4.9.6-21.0.el6_3.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Create network (NET_1) and attach it to interface on the host.
2.Create VM and use the network (NET_1) from step 1.
3.Run the VM
4.While the VM is running detach the network (NET_1) from the host.
  
Actual results:
The network removed from the host.

Expected results:
Should get error that the network is used by running VM and can't be removed.
Comment 2 lpeer 2012-07-16 04:02:07 EDT
we'll block it on the engine side.
There are many validations done only on the engine side I think this should be one of them.

*** This bug has been marked as a duplicate of bug 824497 ***

Note You need to log in before you can comment on or make changes to this bug.