Bug 824578 - [RFE] Search for all packages containing string, not just packages starting with string
[RFE] Search for all packages containing string, not just packages starting w...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Repositories (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity low (vote)
: Unspecified
: --
Assigned To: Brad Buckingham
Og Maciel
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-23 14:57 EDT by james labocki
Modified: 2016-09-13 15:54 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-13 15:54:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description james labocki 2012-05-23 14:57:44 EDT
The search box in SE, searches for packages starting with the name typed. It would be more convenient to search for packages containing such a word.
Comment 1 Mike McCune 2012-05-30 11:10:56 EDT
You can achieve this by using the search syntax:

*office*

would get you all packages containing the word office. 

We have other bugs related to improving how the search syntax works, may roll this one up into an already existing bug
Comment 2 Brad Buckingham 2012-05-31 12:55:39 EDT
The search query language currently supported by SE is based upon the Lucene Query Syntax.  The following is a brief reference to it:
http://lucene.apache.org/core/old_versioned_docs/versions/3_3_0/queryparsersyntax.html

Using this syntax, a user can provide wild cards within the query, as shown in the document and comment 1.

There are a few bugs related to search in SE; however, the one that is most related to this one is bug 805321, which requests the addition of help text or instructions to assist the user with the syntax.

There has also been some side discussions of potentially moving away from using the Lucent Query Syntax and creating our own syntax for the product; however, that has not been formally planned.
Comment 4 Mike McCune 2013-08-16 14:16:04 EDT
getting rid of 6.0.0 version since that doesn't exist
Comment 6 Bryan Kearney 2016-07-08 16:49:09 EDT
Per 6.3 planning, moving out non acked bugs to the backlog
Comment 8 Justin Sherrill 2016-09-13 15:54:52 EDT
This should be accomplished via:

name ~ foo

in Satellite 6.2

Note You need to log in before you can comment on or make changes to this bug.