Bug 824594 - Xephr apps are all black
Xephr apps are all black
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
: 737683 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-23 15:44 EDT by Daniel Walsh
Modified: 2012-06-25 20:40 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-25 20:40:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Walsh 2012-05-23 15:44:02 EDT
Description of problem:

Every Xephyr window comes up black, if I downgrade to f17 version everything works.  Certainly breaks sandbox badly.
Comment 1 Daniel Walsh 2012-06-18 12:01:14 EDT
 /usr/bin/Xephyr -displayfd 10
_XSERVTransSocketUNIXCreateListener: ...SocketCreateListener() failed
_XSERVTransMakeAllCOTSServerListeners: server already running


This is the cause.


Can some one look at this?  It is now in Fedora 17.
Comment 2 Daniel Walsh 2012-06-18 12:01:35 EDT
All sandbox apps are now broken.
Comment 3 Daniel Walsh 2012-06-18 12:02:20 EDT
*** Bug 737683 has been marked as a duplicate of this bug. ***
Comment 4 Kevin Fenzi 2012-06-18 12:12:10 EDT
I am seeing this here too. :( 

This is quite anoying, as you can't use X sandbox at all with this bug.
Comment 5 Simo Sorce 2012-06-20 12:08:45 EDT
Up, can we get at least an acknowledgement from the maintainer ?
Comment 6 Peter Hutterer 2012-06-20 21:43:00 EDT
(In reply to comment #1)
>  /usr/bin/Xephyr -displayfd 10
> _XSERVTransSocketUNIXCreateListener: ...SocketCreateListener() failed
> _XSERVTransMakeAllCOTSServerListeners: server already running

this usually means you're conflicting with the existing server if $DISPLAY is :0.
/usr/bin/Xephyr -displayfd 10 :1
does that work?
Comment 7 Peter Hutterer 2012-06-21 01:09:26 EDT
sorry, ECOFFEE, didn't think of displayfd properly.

Issue:
Fedora's displayfd patch printed a newline after the DISPLAY. The patch that got merged upstream doesn't, so you're not actually reading the DISPLAY until Xephyr exists.

_XSERVTransSocketUNIXCreateListener: ...SocketCreateListener() failed
_XSERVTransMakeAllCOTSServerListeners: server already running

This is a warning printed once for each display socket that was tried but didn't succeed. It has no effect otherwise and can be ignored when running with -displayfd.


Reference: xserver commit 88bacc49f06da5927f716869f5a32672a8297ed0

Got a build coming up for this.
Comment 8 Fedora Update System 2012-06-21 01:19:28 EDT
xorg-x11-server-1.12.2-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/xorg-x11-server-1.12.2-3.fc17
Comment 9 Fedora Update System 2012-06-22 04:38:50 EDT
Package xorg-x11-server-1.12.2-3.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xorg-x11-server-1.12.2-3.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-9802/xorg-x11-server-1.12.2-3.fc17
then log in and leave karma (feedback).
Comment 10 Simo Sorce 2012-06-25 08:58:33 EDT
Thanks, I tested the package and it fixed the selinux sandbox, thanks a lot.
submitting karma in a few moments.
Comment 11 Fedora Update System 2012-06-25 20:40:57 EDT
xorg-x11-server-1.12.2-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.