Bug 82473 - Please provide gtkmm
Summary: Please provide gtkmm
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: distribution (Show other bugs)
(Show other bugs)
Version: 9
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact:
URL: http://www.gtkmm.org
Whiteboard:
Keywords: FutureFeature, Triaged
: 120805 (view as bug list)
Depends On:
Blocks: 82476
TreeView+ depends on / blocked
 
Reported: 2003-01-22 15:47 UTC by Murray Cumming
Modified: 2007-04-18 16:50 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-06 17:17:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Murray Cumming 2003-01-22 15:47:43 UTC
Please provide rpms of gtkmm 2
(http://www.gtkmm.org)

Even if you don't want to distribute one of the applications that uses gtkmm,
there are many corporations who use gtkmm for in-house applications and would
like an easier way to distribute their software.

We have .spec files for gtkmm 2 and libsigc++ 1.2 which might help you.

While you're at it, libglademm 2, gconfmm 2, and libgnomecanvasmm 2 would also
be useful. They are all API/ABI stable.

Comment 1 Ross Burton 2003-01-22 15:52:32 UTC
This is simply a "me too" comment.  We are planning on replacing our aging
RedHat 7.3 machines with RH8.1 when it is out, and not having to rebuild gtkmm2
from source to develop would be a Good Thing for us.

Thanks.

Comment 2 Billy O'Connor 2003-01-23 23:30:40 UTC
I'd also like to see the gtkmm/gnomemm libraries added to the next version of Red 
Hat. 

Comment 3 Barnaby Gray 2003-01-24 00:26:38 UTC
I agree. A must have, for the developers' sanity if anything!

Barnaby

Comment 4 David Bellot 2003-01-24 08:39:31 UTC
A lot of applications are using gtkmm/gnomemm/libglademm etc...
We must have those libraries included in RH8.0/RH8.1/...

Thanks


Comment 5 Sergio Pascual 2003-01-24 10:44:21 UTC
A distribution based mainly on GNOME and GTK should provide the C++ bindings.

I wolud be very gratefull!

Comment 6 Kjell Irgens 2003-01-24 11:09:42 UTC
Our company use gtkmm 2.x commercially in the space industry.  It is a hassle to
have to install the separately.

Comment 7 Havoc Pennington 2003-02-03 19:43:26 UTC
The package list freeze for the current release was a couple months ago, so 
marking this for future consideration.

Comment 8 Tad Marko 2003-03-03 00:48:15 UTC
Add me to the me too list.

Comment 9 Jeff Beardsley 2003-03-03 04:15:25 UTC
Me too

Comment 10 Daniel Brodie 2003-03-16 06:37:09 UTC
Having a GNOME development desktop offered by Redhat must have bindings for C++
considering that other bindings were provided. It is simply an important part of
the GNOME development enviorment that will go overlooked by many otherwise.

Please include it.
Thanks you!

Comment 11 Greg Yasko 2003-03-16 21:36:03 UTC
Please include gtkmm in your distribution or at least in rpm form.

I'm interested in developing for Gnome but prefer the C++ language, and it's a 
pain to install from source. 



Comment 12 Matthew Baxa 2003-03-16 22:45:45 UTC
In order to provide a better platform for development of C++ code, I believe
that gtkmm should be available as an offical Red Hat package.  Red Hat provides
nearly every other development library as RPMS, it seems inconsistant to not
provide gtkmm.

Comment 13 Will Robinson 2003-03-26 09:12:56 UTC
I'd usually try to avoid "me too" posts to bugzilla, but since the point of this
bug seems to be to assess user sentiment, I thought I should add my vote for
packaging gtkmm and related software.  There are a lot of people (including me)
who would be most comfortable developing GUI apps for GNOME using C++, and
providing these bindings out-of-the-box will make it easier for these people to
get involved.  libglademm would also be a big help in this direction.  Hope
these packages make it in there someday...

Comment 14 Jim Wray 2003-03-27 23:49:04 UTC
Having a full, functioning c++ development platform is crucial.  Currently, we
use QT, but would like to try gtkmm.  I would like to a see a platform, where I
don't have to re-install glade, add-in gtkmm, gnomemm, and etc to accomplish
easy c++ development.  I would love to see my favorite distribution add this
into their arsenal of other high quality libraries and development tools.

Here's hopin'!  Even though it looks like its not going to be in RH9, please
make sure you integrate this functionality into RH10 (or whatever you choose to
call it)

Thanks.

Comment 15 Michel Fodje 2003-03-28 14:53:24 UTC
Me too.

Comment 16 sebastiano bondì 2003-03-30 09:26:38 UTC
I don't understand the reasons of your choice.
Please include gtkmm in your distribution.
Gabber needs it!!

Comment 17 Havoc Pennington 2003-03-30 17:43:08 UTC
OK guys, normally I close bugs with a bunch of "me too" after about the second
"me too" - can we please stop? It is not going to convince anybody to have one
more "me too" on top of what's here, you are just spamming me at this point.

Comment 18 mahoney lanl 2003-04-29 18:34:57 UTC
I am looking for gtkmm. All I wanted to do was compiled workrave at sf.net

Comment 19 David Bellot 2003-05-02 10:35:42 UTC
We need to have official gtkmm/gnomemm/canvasmm/glademm/etc.. for RH 9, in order
to port our business to RH 9 too. This is vital for us !
Thanks !

Comment 20 Need Real Name 2003-05-04 15:14:49 UTC
Since you have enough me-too comments, you may want to change
http://gtkmm.sourceforge.net/download.shtml where it says "# RedHat Linux:
Please request them here, giving reasons.", which points at this bug report...

Comment 21 Ron Wills 2003-05-07 03:15:38 UTC
I need it to run gabber for redhat 8.0 which I'm surprised is not part of the distro

Comment 22 Scott J. Gottfried 2003-05-11 18:25:04 UTC
Needed to install firewall builder on RH.

Comment 23 matt tebo 2003-05-14 16:05:47 UTC
need for fwbuilder on redhat

Comment 24 Greg Stark 2003-06-25 09:08:00 UTC
need for fwbuilder on RH
Also libsigc++

Comment 25 Greg Stark 2003-06-25 09:21:33 UTC
Sorry, let me back out my earlier comment.  I was not trying to spam you 
Havoc.  I would like to know; What tips the balance for RH to provide an rpm 
for these.

I want to install fwbuilder on an RH9 box. gtkmm and libsigc++ are required.  
The authors are recommending I install the Debian packages or build them.  I 
don't like doing either.

Comment 26 Ariel Calò 2003-07-15 09:04:11 UTC
please do it also for 9.x releases

Comment 27 Carlos Lang 2003-08-16 03:40:24 UTC
interested in this as much as the other folks.  would be great to have.

Comment 28 bert hubert 2003-09-15 06:55:50 UTC
This is Bert Hubert from the LARTC project, and I'm currently writing a very
cool tool to configure QoS classes and it depends on gtkmm-2.0, so please,
please, please add this library to redhat!

Comment 29 Murray Cumming 2003-12-06 17:17:19 UTC
gtkmm (and other *mm packages) is now available for Fedora Core (the
successor to RedHat Linux) so we can expect it to be available for a
future Fedora-based RedHat Enterprise Linux.

There are also versions of the RPMs for Red Hat Linux 9, which I guess
will work with the most recent Red Hat Enterprise Linux 3.

So I consider this fixed. Thank you for your support.

Comment 30 Bill Nottingham 2004-04-14 03:18:45 UTC
*** Bug 120805 has been marked as a duplicate of this bug. ***

Comment 31 Denis Leroy 2004-06-05 00:15:05 UTC
I would like to request this bug being re-opened.

The gtkmm2 libraries were part of FC1 "Extras" (i.e. fedora.us), but
were dropped out of FC2 Extras, causing much grief among gtkmm2-based
app developpers (i'm one of them). There's a bug open on
bugzilla.fedora.us, but it'll take some time before anything happens.

We would like to formally request that the gtkmm2 family of libraries
be officially part of the Fedora Core instead of the Extras. We feel
it's important to provide the opportunity for developpers to create
Gnome applications in C++ and give those apps a realistic chance to
compete in the open-source world. Certainly, the C++ Gtk/Gnome
bindings should be treated with the same priority as the Python and
Perl GTK bindings, which i feel is not the case right now. My
experience working with gtkmm has been remarkable, the project is
stable and mature and worthy of more public exposure.

As an example (biased, since i'm working on that project),
cdrdao-1.1.8 is currently part of FC2 Core, but it's built with its
GUI front-end disabled because of its dependency to gtkmm2.

Cheers,
-denis



Note You need to log in before you can comment on or make changes to this bug.