Bug 824824 - apropos returns 0 on non-existing man page
apropos returns 0 on non-existing man page
Status: CLOSED DUPLICATE of bug 824825
Product: Fedora
Classification: Fedora
Component: man-db (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Schiffer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-24 07:31 EDT by Martin Kyral
Modified: 2012-05-24 07:58 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-24 07:58:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Martin Kyral 2012-05-24 07:31:15 EDT
Description of problem:
Apropos nosuchmanpage return code is 0. It shall be 16 accoprding to man apropos.

Version-Release number of selected component (if applicable):
man-db-2.6.0.2-3.fc16.x86_64

How reproducible:
Always

Steps to Reproduce:
1. apropos nosuchmanpage
2. echo $?
  
Actual results:
0

Expected results:
16

Additional info:
The bug is fixed upstream: http://www.mail-archive.com/debian-bugs-dist@lists.debian.org/msg1021804.html
Comment 1 Martin Kyral 2012-05-24 07:58:30 EDT

*** This bug has been marked as a duplicate of bug 824825 ***

Note You need to log in before you can comment on or make changes to this bug.