Bug 824825 - apropos returns 0 on non-existing man page
apropos returns 0 on non-existing man page
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: man-db (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Schiffer
Fedora Extras Quality Assurance
:
: 824824 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-24 07:31 EDT by Martin Kyral
Modified: 2012-07-23 16:23 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-20 22:54:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Kyral 2012-05-24 07:31:40 EDT
Description of problem:
'apropos nosuchmanpage' return code is 0. It shall be 16 accoprding to man apropos.

Version-Release number of selected component (if applicable):
man-db-2.6.0.2-3.fc16.x86_64

How reproducible:
Always

Steps to Reproduce:
1. apropos nosuchmanpage
2. echo $?
  
Actual results:
0

Expected results:
16

Additional info:
The bug is fixed upstream: http://www.mail-archive.com/debian-bugs-dist@lists.debian.org/msg1021804.html
Comment 1 Martin Kyral 2012-05-24 07:58:30 EDT
*** Bug 824824 has been marked as a duplicate of this bug. ***
Comment 2 Peter Schiffer 2012-07-10 14:33:34 EDT
fixed in:
man-db-2.6.2-1.fc18
http://koji.fedoraproject.org/koji/buildinfo?buildID=329909
Comment 3 Fedora Update System 2012-07-12 12:26:52 EDT
man-db-2.6.0.2-7.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/man-db-2.6.0.2-7.fc17
Comment 4 Fedora Update System 2012-07-12 12:52:12 EDT
man-db-2.6.0.2-4.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/man-db-2.6.0.2-4.fc16
Comment 5 Fedora Update System 2012-07-14 17:58:13 EDT
Package man-db-2.6.0.2-7.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing man-db-2.6.0.2-7.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-10644/man-db-2.6.0.2-7.fc17
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2012-07-20 22:54:20 EDT
man-db-2.6.0.2-7.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2012-07-23 16:23:24 EDT
man-db-2.6.0.2-4.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.