Bug 825449 - AbiWord and gedit don't spellcheck without enchant-aspell, but it's not a dependency
AbiWord and gedit don't spellcheck without enchant-aspell, but it's not a dep...
Status: CLOSED DUPLICATE of bug 573516
Product: Fedora
Classification: Fedora
Component: spin-kickstarts (Show other bugs)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeroen van Meeuwen
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2012-05-26 07:01 EDT by Steven Usdansky
Modified: 2012-08-01 04:46 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2012-08-01 04:46:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Steven Usdansky 2012-05-26 07:01:26 EDT
Description of problem:
Spell checking doesn't work without enchant-aspell installed, and the AbiWord installation does not pull this dep in.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Install AbiWord along with aspell-en. Pulls in aspell, libabiword, link-grammar
   as deps
2. Run AbiWord
3. Try to use spell check
Actual results:
Spell check does not work; toolbar icon is grayed out

Expected results:
Misspelled words are underlined with red squiggly line

Additional info:
1. Installing enchant-aspell solves this problem
2. This bug is not new to F17 - see # 818995
Comment 1 Máirín Duffy 2012-07-31 22:20:09 EDT
Hi, a Fedora 17 user reported this was affecting gedit as well, so i've modified the bug description.

I believe the reason this is happening is because the aspell dictionaries were removed from the Fedora desktop spin (which is a live image meant for ~700mb on a DVD) to save space. I think, since the desktop spin is targeted at English-speaking users, that the enchant-aspell english US dictionary, which from some quick research looks to be 1.7MB, should be included in the KS file for the desktop spin by default so we ship with functioning spell checking in our wordprocessor, text editor (and i'm guessing other default included apps like evolution mail are affected as well.)

Moving to aspell because I think the 'bug' is in the desktop spin kickstart file and there's no component for that, and I'll bring it up on the fedora desktop-devel list.
Comment 2 Máirín Duffy 2012-07-31 22:21:56 EDT
(Symptoms as described by gedit user:

"I can't figure out how to get spell-check working in #gedit. I am running Fedora 17, and when I try to select a language there are none for me to select. 'Tools -> Set Language...' was blank [in the spell checking menu item.] After installing enchant-aspell it was populated with four options of English (vanilla, Canada, UK, US).

"I was getting conflicting info on the web about whether or not #gedit uses #aspell or #hunspell. hunspell was installed, aspell was not. Installing aspell did not solve it for me." )
Comment 3 Máirín Duffy 2012-07-31 22:25:59 EDT
Well, you learn something new every day. I didn't know there was a spins-kickstart component. Re-filing there.
Comment 4 Caolan McNamara 2012-08-01 04:46:14 EDT
aspell is a red herring really. link-grammar is still requiring that, leading people to thing that they should install aspell dictionaries and then enchant-aspell to use them, all of which does give working spell checking, but presumably its really missing hunspell-en dictionaries at the root of it

*** This bug has been marked as a duplicate of bug 573516 ***

Note You need to log in before you can comment on or make changes to this bug.