Bug 825501 - [abrt] python-2.7.3-6.fc17: virNetClientCallQueue: Process /usr/bin/python2.7 was killed by signal 11 (SIGSEGV)
[abrt] python-2.7.3-6.fc17: virNetClientCallQueue: Process /usr/bin/python2.7...
Status: CLOSED DUPLICATE of bug 805950
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
abrt_hash:4f265205a39f47ccef37d3c698e...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-26 19:14 EDT by Juan Orti
Modified: 2012-06-26 10:57 EDT (History)
18 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-26 10:57:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (78.62 KB, text/plain)
2012-05-26 19:14 EDT, Juan Orti
no flags Details
File: maps (78.08 KB, text/plain)
2012-05-26 19:14 EDT, Juan Orti
no flags Details
File: dso_list (16.86 KB, text/plain)
2012-05-26 19:14 EDT, Juan Orti
no flags Details
File: build_ids (6.73 KB, text/plain)
2012-05-26 19:14 EDT, Juan Orti
no flags Details
File: var_log_messages (12.73 KB, text/plain)
2012-05-26 19:14 EDT, Juan Orti
no flags Details

  None (edit)
Description Juan Orti 2012-05-26 19:14:17 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        /usr/bin/python /usr/share/virt-manager/virt-manager.py
crash_function: virNetClientCallQueue
executable:     /usr/bin/python2.7
kernel:         3.3.7-1.fc17.x86_64
pid:            2773
pwd:            /home/juan
time:           sáb 26 may 2012 17:28:06 CEST
uid:            1000
username:       juan
xsession_errors: 

backtrace:      Text file, 80508 bytes
build_ids:      Text file, 6888 bytes
dso_list:       Text file, 17262 bytes
maps:           Text file, 79953 bytes
var_log_messages: Text file, 13031 bytes

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/juan/2

comment:
:I created a new virtual machine, nothing special: a ISO for installing, a qcow2 disk file, spice, and qxl video card.
:In the last step, when I clicked start installation, it showed me an error.

core_backtrace:
:6f75c6fa02f0546dd6d525798bde8fec32d99f0c 0x125783 - libvirt.so.0 -
:6f75c6fa02f0546dd6d525798bde8fec32d99f0c 0x126a4b - libvirt.so.0 -
:6f75c6fa02f0546dd6d525798bde8fec32d99f0c 0x12723b - libvirt.so.0 -
:6f75c6fa02f0546dd6d525798bde8fec32d99f0c 0x109d58 - libvirt.so.0 -
:6f75c6fa02f0546dd6d525798bde8fec32d99f0c 0x10adf7 - libvirt.so.0 -
:6f75c6fa02f0546dd6d525798bde8fec32d99f0c 0xee745 virStoragePoolRefresh libvirt.so.0 -
:0360edbd55c9b16f1cd4b4d0c7360148571af82e 0x26d9e libvirt_virStoragePoolRefresh libvirtmod.so -
:efb4769976ac3cc8192277706894a2d7b3256ed1 0xdd0f1 PyEval_EvalFrameEx libpython2.7.so.1.0 -
:efb4769976ac3cc8192277706894a2d7b3256ed1 0xdcd61 PyEval_EvalFrameEx libpython2.7.so.1.0 -
:efb4769976ac3cc8192277706894a2d7b3256ed1 0xdcd61 PyEval_EvalFrameEx libpython2.7.so.1.0 -
:efb4769976ac3cc8192277706894a2d7b3256ed1 0xdcd61 PyEval_EvalFrameEx libpython2.7.so.1.0 -
:efb4769976ac3cc8192277706894a2d7b3256ed1 0xddb2f PyEval_EvalCodeEx libpython2.7.so.1.0 -
:efb4769976ac3cc8192277706894a2d7b3256ed1 0x6d7b6 - libpython2.7.so.1.0 -
:efb4769976ac3cc8192277706894a2d7b3256ed1 0x49a7e PyObject_Call libpython2.7.so.1.0 -
:efb4769976ac3cc8192277706894a2d7b3256ed1 0xd9efb PyEval_EvalFrameEx libpython2.7.so.1.0 -
:efb4769976ac3cc8192277706894a2d7b3256ed1 0xddb2f PyEval_EvalCodeEx libpython2.7.so.1.0 -
:efb4769976ac3cc8192277706894a2d7b3256ed1 0x6d7b6 - libpython2.7.so.1.0 -
:efb4769976ac3cc8192277706894a2d7b3256ed1 0x49a7e PyObject_Call libpython2.7.so.1.0 -
:efb4769976ac3cc8192277706894a2d7b3256ed1 0xd71d7 PyEval_CallObjectWithKeywords libpython2.7.so.1.0 -
:476584fc83ed85f46df7a5b3fbaef5aac717c925 0x26a8 _pyglib_handler_marshal libpyglib-2.0-python.so.0 -
:e5945f7dae3fc83ad499da1ea5a464bfa0e68202 0x4827b - libglib-2.0.so.0 -
:e5945f7dae3fc83ad499da1ea5a464bfa0e68202 0x476e5 g_main_context_dispatch libglib-2.0.so.0 -
:e5945f7dae3fc83ad499da1ea5a464bfa0e68202 0x47a18 - libglib-2.0.so.0 -
:e5945f7dae3fc83ad499da1ea5a464bfa0e68202 0x47e12 g_main_loop_run libglib-2.0.so.0 -
:f6d72221cbd08cb36bb88823d33deb2024f2bee3 0x149d67 gtk_main libgtk-x11-2.0.so.0 -
:e4ee09219dd69e5a1f6b06fb78c7488a3a6260df 0x1a65a8 - _gtk.so -
:efb4769976ac3cc8192277706894a2d7b3256ed1 0xdce46 PyEval_EvalFrameEx libpython2.7.so.1.0 -
:efb4769976ac3cc8192277706894a2d7b3256ed1 0xdcd61 PyEval_EvalFrameEx libpython2.7.so.1.0 -
:efb4769976ac3cc8192277706894a2d7b3256ed1 0xddb2f PyEval_EvalCodeEx libpython2.7.so.1.0 -
:efb4769976ac3cc8192277706894a2d7b3256ed1 0xddc02 PyEval_EvalCode libpython2.7.so.1.0 -
:efb4769976ac3cc8192277706894a2d7b3256ed1 0xf6baa - libpython2.7.so.1.0 -
:efb4769976ac3cc8192277706894a2d7b3256ed1 0xf79a2 PyRun_FileExFlags libpython2.7.so.1.0 -
:efb4769976ac3cc8192277706894a2d7b3256ed1 0xf83bb PyRun_SimpleFileExFlags libpython2.7.so.1.0 -
:efb4769976ac3cc8192277706894a2d7b3256ed1 0x109892 Py_Main libpython2.7.so.1.0 -

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=2
:HOSTNAME=xenon.miceliux.com
:GIO_LAUNCHED_DESKTOP_FILE_PID=2770
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:GPG_AGENT_INFO=/run/user/juan/keyring-5XdtN5/gpg:0:1
:TERM=dumb
:SHELL=/bin/bash
:HISTSIZE=1000
:GJS_DEBUG_OUTPUT=stderr
:GNOME_KEYRING_CONTROL=/run/user/juan/keyring-5XdtN5
:'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
:IMSETTINGS_MODULE=none
:QT_GRAPHICSSYSTEM_CHECKED=1
:USER=juan
:SSH_AUTH_SOCK=/run/user/juan/keyring-5XdtN5/ssh
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1483,unix/unix:/tmp/.ICE-unix/1483
:USERNAME=juan
:GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/virt-manager.desktop
:DESKTOP_SESSION=gnome
:PATH=/usr/lib64/ccache:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/home/juan/.local/bin:/home/juan/bin
:MAIL=/var/spool/mail/juan
:_=/usr/bin/gnome-session
:QT_IM_MODULE=xim
:PWD=/home/juan
:XMODIFIERS=@im=none
:LANG=es_ES.utf8
:GNOME_KEYRING_PID=1476
:GDM_LANG=es_ES.utf8
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:SHLVL=1
:HOME=/home/juan
:XDG_SEAT=seat0
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:LOGNAME=juan
:CVS_RSH=ssh
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-MhUO2cVBDG,guid=5b6a6210e4886bcc060f02930000001b
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:DISPLAY=:0
:XDG_RUNTIME_DIR=/run/user/juan
:XAUTHORITY=/var/run/gdm/auth-for-juan-n9QO0T/database
:CCACHE_HASHDIR=

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 125911               processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       125911               125911               signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/null
:pos:	0
:flags:	0100002
:1:/dev/null
:pos:	0
:flags:	0100002
:2:/dev/null
:pos:	0
:flags:	0100002
:3:/home/juan/.virt-manager/virt-manager.log
:pos:	55662
:flags:	0102001
:4:socket:[41211]
:pos:	0
:flags:	02004002
:5:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:6:/dev/urandom
:pos:	0
:flags:	02100000
:7:socket:[30519]
:pos:	0
:flags:	02000002
:8:socket:[40694]
:pos:	0
:flags:	02004002
:9:socket:[41212]
:pos:	0
:flags:	02004002
:10:socket:[40700]
:pos:	0
:flags:	02004002
:11:pipe:[40703]
:pos:	0
:flags:	00
:12:pipe:[40703]
:pos:	0
:flags:	04001
:13:socket:[26609]
:pos:	0
:flags:	02004002
:14:pipe:[26610]
:pos:	0
:flags:	02000000
:15:pipe:[26610]
:pos:	0
:flags:	02000001
:16:anon_inode:inotify
:pos:	0
:flags:	02004000

smolt_data:
:
:
:General
:=================================
:UUID: 6e6fca7d-59b3-4075-bd23-83f50d1e623d
:SO: Fedora release 17 (Beefy Miracle)
:Nivel de ejecución por defecto: Unknown
:Idioma: es_ES.utf8
:Plataforma: x86_64
:BogoMIPS: 6822.18
:Fabricante de CPU: GenuineIntel
:Modelo de CPU: Intel(R) Core(TM) i7-2600K CPU @ 3.40GHz
:Paso del UCP: 7
:Familia de UCP: 6
:Número de Modelo de CPU: 42
:Número de CPUs: 8
:Velocidad del CPU: 3401
:Memoria del Sistema: 15758
:Intercambio (swap) del Sistema: 7999
:Vendedor: System manufacturer
:Sistema: System Product Name System Version
:Factor de forma: Desktop
:Kernel: 3.3.7-1.fc17.x86_64
:SELinux Habilitado: 1
:Política de SELinux: targeted
:SELinux Obligado: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Dispositivos
:=================================
:(6945:4162:4163:33928) pci, xhci_hcd, USB, ASM1042 SuperSpeed USB Host Controller
:(6945:4162:4163:33928) pci, xhci_hcd, USB, ASM1042 SuperSpeed USB Host Controller
:(32902:290:4163:33869) pci, i915, VIDEO, 2nd Generation Core Processor Family Integrated Graphics Controller
:(32902:7170:4163:33869) pci, ahci, STORAGE, P8P67 Deluxe Motherboard
:(32902:7184:4163:33869) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 1
:(32902:7236:4163:33869) pci, None, PCI/ISA, Z68 Express Chipset Family LPC Controller
:(32902:7196:4163:33869) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 7
:(32902:9294:4163:33869) pci, None, PCI/PCI, 82801 PCI Bridge
:(32902:7192:4163:33869) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 5
:(32902:7200:4163:33819) pci, snd_hda_intel, MULTIMEDIA, 6 Series/C200 Series Chipset Family High Definition Audio Controller
:(6945:4224:4163:33929) pci, None, PCI/PCI, N/A
:(32902:7202:4163:33869) pci, None, SERIAL, P8P67 Deluxe Motherboard
:(4332:33128:4163:33842) pci, r8169, ETHERNET, P8P67 Deluxe Motherboard [Realtek RTL8111E]
:(32902:7213:4163:33869) pci, ehci_hcd, USB, P8P67 Deluxe Motherboard
:(32902:7206:4163:33869) pci, ehci_hcd, USB, P8P67 Deluxe Motherboard
:(32902:256:4163:33869) pci, agpgart-intel, HOST/PCI, P8P67 Deluxe Motherboard
:(32902:7226:4163:33869) pci, None, SIMPLE, P8P67 Deluxe Motherboard
:(5772:26:5868:290) pci, ath5k, ETHERNET, Wireless PCI Adapter Model 5418
:(32902:7194:4163:33869) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 6
:(32902:257:4163:33869) pci, pcieport, PCI/PCI, Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port
:
:
:Información relacionada con el sistema de archivos
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/vg_ssd-root / ext4 4096 4096 10218049 8913092 8401092 2564096 2382922 2382922
:/dev/sda2 /boot ext4 4096 4096 261467 234210 221103 65536 65192 65192
:/dev/mapper/vg_ssd-var /var ext4 4096 4096 16723892 16168421 15330789 4194304 4169420 4169420
:/dev/mapper/vg_raid5-libvirt WITHHELD ext4 4096 4096 76712862 74669585 70829585 19202048 19202020 19202020
:/dev/mapper/vg_raid5-home /home ext4 4096 4096 511510557 261597542 235997542 128000000 127604894 127604894
:
Comment 1 Juan Orti 2012-05-26 19:14:25 EDT
Created attachment 587048 [details]
File: backtrace
Comment 2 Juan Orti 2012-05-26 19:14:28 EDT
Created attachment 587049 [details]
File: maps
Comment 3 Juan Orti 2012-05-26 19:14:31 EDT
Created attachment 587050 [details]
File: dso_list
Comment 4 Juan Orti 2012-05-26 19:14:33 EDT
Created attachment 587051 [details]
File: build_ids
Comment 5 Juan Orti 2012-05-26 19:14:35 EDT
Created attachment 587052 [details]
File: var_log_messages
Comment 6 Dave Malcolm 2012-05-29 08:53:59 EDT
Thanks for filing this bug report.

Looking at the backtrace in attachment 587048 [details] I see that the SIGSEGV occurred in thread 1 frame 1 within virNetClientCallQueue within a call to virStoragePoolRefresh in frame 8.  (This was called by libvirt_virStoragePoolRefresh in freame 9, in turn called from python, so I'm assuming that this was an explicit call to the wrapped virStoragePoolRefresh from virt-manager's python code.  This appears to have been triggered by a timeout in frame 32).

Reassigning from python to libvirt.
Comment 7 Cole Robinson 2012-06-07 17:53:26 EDT
There's some threading issues in virt-manager here that are causing issues
Comment 8 Cole Robinson 2012-06-26 10:57:44 EDT

*** This bug has been marked as a duplicate of bug 805950 ***

Note You need to log in before you can comment on or make changes to this bug.