Bug 805950 - Crash in virNetSocketWriteWire when deleting volumes in virt-manager
Crash in virNetSocketWriteWire when deleting volumes in virt-manager
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
abrt_hash:c4018b63d6010526b20a39e7026...
:
: 749234 810501 813252 817191 825501 830466 842491 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-22 10:22 EDT by Alexey Pakseykin
Modified: 2012-08-09 19:23 EDT (History)
19 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-09 19:02:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dso_list (18.27 KB, text/plain)
2012-03-22 10:22 EDT, Alexey Pakseykin
no flags Details
File: build_ids (7.73 KB, text/plain)
2012-03-22 10:22 EDT, Alexey Pakseykin
no flags Details
File: smolt_data (4.10 KB, text/plain)
2012-03-22 10:22 EDT, Alexey Pakseykin
no flags Details
File: maps (78.27 KB, text/plain)
2012-03-22 10:22 EDT, Alexey Pakseykin
no flags Details
File: backtrace (140.64 KB, text/plain)
2012-03-22 10:23 EDT, Alexey Pakseykin
no flags Details

  None (edit)
Description Alexey Pakseykin 2012-03-22 10:22:47 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
backtrace_rating: 4
cmdline:        /usr/bin/python /usr/share/virt-manager/virt-manager.py
crash_function: write
executable:     /usr/bin/python
kernel:         3.2.10-3.fc16.x86_64
pid:            3368
pwd:            /home/pakseykin
reason:         Process /usr/bin/python was killed by signal 11 (SIGSEGV)
time:           Thu 22 Mar 2012 09:56:29 PM SGT
uid:            1001
username:       pakseykin
xsession_errors: 

backtrace:      Text file, 144011 bytes
build_ids:      Text file, 7913 bytes
dso_list:       Text file, 18706 bytes
maps:           Text file, 80149 bytes
smolt_data:     Text file, 4196 bytes

comment:
:I was removing volumes one by one in "Storage" tab of "Connection Details" dialog until it crashed during deletion of next file.
:
:After restarting it, I continued deleting the rest of files. The problem persisted. The crashes happened with different image files and appeared randomly (deletion seems always successful, but some of them are followed by the crash, some aren't). The images were not used by any of the VMs (only single VM was configured).
:The images were in raw format and were created on Fedora 15 (currently F16) and left since OS reinstallation without re-creating VMs for them.
:

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=2
:LC_MONETARY=en_US.utf8
:HOSTNAME=master.pakseykin
:GIO_LAUNCHED_DESKTOP_FILE_PID=3365
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:GPG_AGENT_INFO=/tmp/keyring-wMpX9g/gpg:0:1
:TERM=dumb
:SHELL=/bin/bash
:XDG_SESSION_COOKIE=ae7069cb3e83bfd5e98a88ac0000000c-1332422688.152253-1551918258
:HISTSIZE=1000
:GJS_DEBUG_OUTPUT=stderr
:LC_NUMERIC=en_US.utf8
:GNOME_KEYRING_CONTROL=/tmp/keyring-wMpX9g
:QTDIR=/usr/lib64/qt-3.3
:'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
:QTINC=/usr/lib64/qt-3.3/include
:IMSETTINGS_MODULE=none
:USER=pakseykin
:SSH_AUTH_SOCK=/tmp/keyring-wMpX9g/ssh
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1849,unix/unix:/tmp/.ICE-unix/1849
:USERNAME=pakseykin
:GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/virt-manager.desktop
:DESKTOP_SESSION=gnome
:PATH=/usr/lib64/qt-3.3/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/pakseykin/.local/bin:/home/pakseykin/bin
:MAIL=/var/spool/mail/pakseykin
:_=/usr/bin/gnome-session
:QT_IM_MODULE=xim
:PWD=/home/pakseykin
:XMODIFIERS=@im=none
:EDITOR=vi
:LANG=en_US.UTF-8
:GNOME_KEYRING_PID=1840
:KDE_IS_PRELINKED=1
:LC_MEASUREMENT=en_US.utf8
:KDEDIRS=/usr
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass
:SHLVL=1
:XDG_SEAT=seat0
:HOME=/home/pakseykin
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:LOGNAME=pakseykin
:QTLIB=/usr/lib64/qt-3.3/lib
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-gJRU2sA6Xg,guid=64c6caa615071e41346155de00000093
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:DISPLAY=:0
:XDG_RUNTIME_DIR=/run/user/pakseykin
:LC_TIME=en_US.utf8
:XAUTHORITY=/var/run/gdm/auth-for-pakseykin-EYNDpT/database

var_log_messages:
:Mar 19 20:54:26 master yum[5419]: Updated: kross-python-4.8.1-1.fc16.x86_64
:Mar 19 20:56:21 master yum[5419]: Updated: liblouis-python-2.4.1-1.fc16.noarch
:Mar 19 20:56:25 master yum[5419]: Updated: plasma-scriptengine-python-4.8.1-6.fc16.x86_64
:Mar 19 20:57:08 master yum[5419]: Updated: libvirt-python-0.9.6-5.fc16.x86_64
:Mar 22 21:56:28 master kernel: [ 2047.852637] python[3368]: segfault at 10 ip 0000003a2699e3ff sp 00007fffff425a60 error 4 in libgtk-x11-2.0.so.0.2400.8[3a26800000+46c000]
:Mar 22 21:56:29 master abrt[9480]: Saved core dump of pid 3368 (/usr/bin/python) to /var/spool/abrt/ccpp-2012-03-22-21:56:29-3368 (52895744 bytes)
Comment 1 Alexey Pakseykin 2012-03-22 10:22:52 EDT
Created attachment 572007 [details]
File: dso_list
Comment 2 Alexey Pakseykin 2012-03-22 10:22:54 EDT
Created attachment 572008 [details]
File: build_ids
Comment 3 Alexey Pakseykin 2012-03-22 10:22:57 EDT
Created attachment 572009 [details]
File: smolt_data
Comment 4 Alexey Pakseykin 2012-03-22 10:22:59 EDT
Created attachment 572010 [details]
File: maps
Comment 5 Alexey Pakseykin 2012-03-22 10:23:03 EDT
Created attachment 572011 [details]
File: backtrace
Comment 6 Cole Robinson 2012-04-02 18:14:28 EDT
Reassigning to libvirt
Comment 7 Cole Robinson 2012-06-07 16:07:34 EDT
Actually there's a virt-manager fix for this IIRC (note to self: pull the fix out of the RHEL6 package)
Comment 8 Cole Robinson 2012-06-26 10:57:44 EDT
*** Bug 825501 has been marked as a duplicate of this bug. ***
Comment 9 Cole Robinson 2012-06-26 10:58:40 EDT
*** Bug 830466 has been marked as a duplicate of this bug. ***
Comment 10 Cole Robinson 2012-06-26 11:09:36 EDT
*** Bug 817191 has been marked as a duplicate of this bug. ***
Comment 11 Cole Robinson 2012-06-26 11:32:18 EDT
*** Bug 749234 has been marked as a duplicate of this bug. ***
Comment 12 Cole Robinson 2012-06-26 11:43:19 EDT
*** Bug 813252 has been marked as a duplicate of this bug. ***
Comment 13 Cole Robinson 2012-06-26 11:44:49 EDT
*** Bug 810501 has been marked as a duplicate of this bug. ***
Comment 14 Fedora Update System 2012-07-09 18:03:00 EDT
virt-manager-0.9.3-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/virt-manager-0.9.3-1.fc16
Comment 15 Fedora Update System 2012-07-09 18:03:00 EDT
virt-manager-0.9.3-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/virt-manager-0.9.3-1.fc17
Comment 16 Fedora Update System 2012-07-10 16:51:20 EDT
Package virt-manager-0.9.3-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing virt-manager-0.9.3-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-10462/virt-manager-0.9.3-1.fc17
then log in and leave karma (feedback).
Comment 17 Cole Robinson 2012-07-24 11:36:42 EDT
*** Bug 842491 has been marked as a duplicate of this bug. ***
Comment 18 Fedora Update System 2012-07-29 17:23:03 EDT
virt-manager-0.9.4-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/virt-manager-0.9.4-1.fc17
Comment 19 Fedora Update System 2012-07-29 17:24:03 EDT
virt-manager-0.9.4-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/virt-manager-0.9.4-1.fc16
Comment 20 Fedora Update System 2012-08-09 19:02:47 EDT
virt-manager-0.9.4-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 21 Fedora Update System 2012-08-09 19:23:52 EDT
virt-manager-0.9.4-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.