Bug 825525 - Passwordless user (such as guest) cannot select session
Passwordless user (such as guest) cannot select session
Status: CLOSED DUPLICATE of bug 744528
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
17
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Honza Horak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-27 07:50 EDT by Chris Smart
Modified: 2012-05-27 23:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-27 23:55:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Smart 2012-05-27 07:50:58 EDT
Description of problem:
GDM allows a user to select the session they wish to log into (those under /usr/share/xsessions/ such as GNOME, Xfce, KDE, etc). This option however, only occurs after a user has been selected from the list. Selecting a user would ordinarily prompt for the password, however if a user has no password they are automatically logged in with no chance to choose their session/desktop.

In addition, other than simply clicking on the user one can select "Not listed?" and type in the passwordless user's username. This presents a list of sessions, however upon pressing "Sign In" the selected session is reverted to last session and is therefore unsuccessful.

This is particularly an issue for Live CDs where the liveuser has no password, but remixes/spins might have multiple desktops. This may also affect a guest user (xguest?) however I couldn't get this user to show up in gdm so was unable to test.

Version-Release number of selected component (if applicable):
gdm-3.4.1-1.fc17.x86_64
gnome-shell-3.4.1-4.fc17.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Create a user: useradd testuser
2. Remove user's password:  passwd -d testuser
2. Install or create another session.desktop file (e.g. xfce-utils)
3. Attempt to log testuser in to a specific session
  
Actual results:
User cannot select a session, logs into default (gnome.session).

Expected results:
User should be able to log into any available desktops.
Comment 1 Chris Smart 2012-05-27 23:55:17 EDT

*** This bug has been marked as a duplicate of bug 744528 ***

Note You need to log in before you can comment on or make changes to this bug.