Bug 825527 - SELinux is preventing /usr/bin/gtk-gnash from 'create' accesses on the directory .gnash.
SELinux is preventing /usr/bin/gtk-gnash from 'create' accesses on the direct...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:35de55d2c234bc926698a827ee5...
:
: 825528 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-27 08:27 EDT by Michal Nowak
Modified: 2013-03-07 21:13 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-28 04:20:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Nowak 2012-05-27 08:27:53 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.3.7-1.fc17.x86_64
time:           Sun 27 May 2012 02:27:23 PM CEST

description:
:SELinux is preventing /usr/bin/gtk-gnash from 'create' accesses on the directory .gnash.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that gtk-gnash should be allowed create access on the .gnash directory by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep gtk-gnash /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c
:                              0.c1023
:Target Context                unconfined_u:object_r:user_home_t:s0
:Target Objects                .gnash [ dir ]
:Source                        gtk-gnash
:Source Path                   /usr/bin/gtk-gnash
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           gnash-0.8.10-2.fc17.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-125.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.7-1.fc17.x86_64 #1 SMP Mon May 21
:                              22:32:19 UTC 2012 x86_64 x86_64
:Alert Count                   2
:First Seen                    Sun 27 May 2012 02:26:06 PM CEST
:Last Seen                     Sun 27 May 2012 02:27:06 PM CEST
:Local ID                      8145b04c-9839-4a26-86d2-17d9e9dc2659
:
:Raw Audit Messages
:type=AVC msg=audit(1338121626.702:453): avc:  denied  { create } for  pid=27495 comm="gtk-gnash" name=".gnash" scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_t:s0 tclass=dir
:
:
:type=SYSCALL msg=audit(1338121626.702:453): arch=x86_64 syscall=mkdir success=no exit=EACCES a0=2c4b258 a1=1c0 a2=1 a3=0 items=0 ppid=27389 pid=27495 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 tty=(none) ses=1 comm=gtk-gnash exe=/usr/bin/gtk-gnash subj=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 key=(null)
:
:Hash: gtk-gnash,mozilla_plugin_t,user_home_t,dir,create
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Miroslav Grepl 2012-05-28 04:05:19 EDT
*** Bug 825528 has been marked as a duplicate of this bug. ***
Comment 2 Miroslav Grepl 2012-05-28 04:20:37 EDT
This should work

# runcon -t mozilla_plugin_t -- mkdir /home/mgrepl/.gnash
# ls -dZ ~/.gnash/
drwxrwxr-x. mgrepl mgrepl unconfined_u:object_r:mozilla_home_t:s0 /home/mgrepl/.gnash/

Execute

# restorecon -R -v ~/

Note You need to log in before you can comment on or make changes to this bug.