Bug 825588 - Related actions list near footer is misrendered when viewing a bug via search results
Related actions list near footer is misrendered when viewing a bug via search...
Status: CLOSED DUPLICATE of bug 823216
Product: Bugzilla
Classification: Community
Component: User Interface (Show other bugs)
4.2
Unspecified Unspecified
unspecified Severity low (vote)
: ---
: ---
Assigned To: Simon Green
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-27 21:44 EDT by Simon Baird
Modified: 2014-10-12 18:48 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-27 22:02:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
shows result in my browser (latest firefox on latest fedora) (12.67 KB, image/png)
2012-05-27 21:44 EDT, Simon Baird
no flags Details

  None (edit)
Description Simon Baird 2012-05-27 21:44:57 EDT
Created attachment 587134 [details]
shows result in my browser (latest firefox on latest fedora)

Please see screenshot.

Notice there are two separate related_actions uls and the second one ends up nested inside the other one, which seems like it might be the cause of the problem.

Also the navigation div ends up inside the outer related_actions ul, which also seems wrong.

<ul class="related_actions">
    <li><a href="show_bug.cgi?format=multiple&amp;id=822892">Format For Printing</a></li>
    <li>&nbsp;-&nbsp;<a href="show_bug.cgi?ctype=xml&amp;id=822892">XML</a></li>
    <li>&nbsp;-&nbsp;<a href="enter_bug.cgi?cloned_bug_id=822892">Clone This Bug</a></li>



<ul class="related_actions">
  <li><a href="enter_bug.cgi?product=Errata%20Tool">
      New Bug For 'Errata Tool'</a>&nbsp;-&nbsp;</li>
  <li><a href="show_bug.cgi?format=multiple&amp;id=822892">Format For Printing</a></li>
  <li>&nbsp;-&nbsp;<a href="show_bug.cgi?ctype=xml&amp;id=822892">XML</a></li>
  <li>&nbsp;-&nbsp;<a href="enter_bug.cgi?cloned_bug_id=822892">Clone This
                      Bug</a></li>
  
    <li>&nbsp;-&nbsp;<a href="#">Top of page </a></li>
</ul>

<div class="navigation">
  <b>Bug List:</b>

  (6 of 478)

  <a href="show_bug.cgi?id=825086&amp;list_id=42303">First</a>
  <a href="show_bug.cgi?id=177930&amp;list_id=42303">Last</a>

    <a href="show_bug.cgi?id=823391&amp;list_id=42303">Prev</a>

    <a href="show_bug.cgi?id=822479&amp;list_id=42303">Next</a>

  &nbsp;&nbsp;<a href="buglist.cgi?regetlastlist=42303">Show last search results</a>
</div>

<br>
</ul>
Comment 1 Simon Baird 2012-05-27 21:48:16 EDT
I think it only happens when you click on a bug from a search query result list. To reproduce:

* Click here:
https://bugzilla.redhat.com/buglist.cgi?query_format=advanced&product=Errata%20Tool&target_milestone=2.2.12.2&list_id=42395

* Click on any bug in that list.

* Scroll down.

* Notice related actions links are rendered on top of navigation links.
Comment 2 Simon Baird 2012-05-27 21:55:32 EDT
Updating title for clarity.
Comment 3 Simon Green 2012-05-27 22:02:39 EDT

*** This bug has been marked as a duplicate of bug 823216 ***

Note You need to log in before you can comment on or make changes to this bug.