Bug 82567 - RH80 failed to install on Compaq Deskpro EN P800
RH80 failed to install on Compaq Deskpro EN P800
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-23 09:50 EST by J. Wang
Modified: 2007-04-18 12:50 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:40:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description J. Wang 2003-01-23 09:50:29 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130

Description of problem:
native Compaq Deskpro EN P800 (P3-800, 256MB, WD HD 20GB, Intel 815 Video).
Try to install RH80 from CD media. can't not pass partition. installation exit
abnormally.
(also tried RH73, identical problem)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. regular installation from a local CD-ROM
2. crashed anywhere from first screen, up to partition HD part
3. even before it crashes, contrl+alt+F1 shows a lot of error
    

Actual Results:  crashed and installation aborted

Additional info:

(anaconda:94): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c: line 1142
(gnome_canvas_path_def_any_closed): assertion 'path != NULL' failed
(anaconda:94): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c: line 1142
(gnome_canvas_path_def_any_closed): assertion 'path != NULL' failed
(anaconda:94): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c: line 1142
(gnome_canvas_path_def_any_closed): assertion 'path != NULL' failed
 ....
Comment 1 Michael Fulbright 2003-01-23 10:56:14 EST
Have you tested your media as outlined in bug 75008?
Comment 2 J. Wang 2003-01-27 08:20:18 EST
yes. all media have been tested OK
I also tried other media (a total 3set of RH80 from friends). all failed to install.
Net-installation (FTP) also failed with the same error
Comment 3 Jeremy Katz 2003-01-29 16:58:50 EST
Are there any error messages on tty4 when it crashes?
Comment 4 J. Wang 2003-01-30 08:07:27 EST
no other messages

I took down all other unnecessory components and had RH 80 installed (some
hardware conflicts?) on an internal IDE. now when I plugged them in again, RH80
finds scsi controler and all SCSI disks and updated /etc/sysconfig/hwconf.
However it failed to attach scsi disks (no entry /proc/scsi, no scsi_mod
loaded). after boot, I have to manually insmod scsi_mod and mount filesystems
(don't know how to activate it at boot time)
Comment 5 Michael Fulbright 2003-01-30 16:03:02 EST
What SCSI hardware do you have?
Comment 6 J. Wang 2003-02-04 13:24:35 EST
Adaptec AIC7xxx driver version: 6.2.8
aic7892: Ultra160 Wide Channel A, SCSI Id=7, 32/253 SCBs
Comment 7 Michael Fulbright 2003-02-04 17:49:43 EST
Arjan do you know of any AIC7xxx issues with 8.0?
Comment 8 Arjan van de Ven 2003-02-04 17:55:18 EST
could you try the aic7xxx_old driver instead?
(change the /etc/modules.conf file and then mkinitrd -f
/boot/initrd-2.4.18-14.img 2.4.18-14)
Comment 9 J. Wang 2003-02-05 08:03:33 EST
the system crashes DURING initial installation (hardly passes partition phase),
so that I don't have chance to switch scsi drivers

As I stated, I took all unnecessary components off, including the SCSI
controller and had RH80 installed successfully. Then I plugged all back in and
recreated initrd file (I am using regular aic7xxx driver). system is working fine. 

Comment 10 eric draven 2003-03-14 02:25:55 EST
I'm getting the same problem as Andy, redhat 8 install failing, but on a celeron
300a system. This is my 3rd time trying, same error every time, even tried
installing with kde instead of gnome and am still getting this error. 

(anaconda:76): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c: line 1142
(gnome_canvas_path_def_any_closed): assertion 'path != NULL' failed

above is repeated 8 times, then says
install exited abnormally
sending termination signals...done
sending kill signals...done
disabling swap...
(snip)
unmounting filesystems...
(snip)
ejecting /tmp/cdrom...
you may safely reboot your system
Comment 11 Bugzilla owner 2004-09-30 11:40:26 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.