Bug 82571 - man pages don't display properly
man pages don't display properly
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: man (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Eido Inoue
Ben Levenson
:
Depends On:
Blocks: 79579 CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-01-23 10:39 EST by David Balažic
Modified: 2007-04-18 12:50 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.5m2-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-26 20:05:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Balažic 2003-01-23 10:39:28 EST
Description of problem:

man does not display certain pages properly, for example :

[root@localhost root]# man 8 shutdown   # execute under /usr/bin/screen running 
on VT1, TERM=screen

The top line is missing. Should be :
---cut---
SHUTDOWN(8)           Linux System Administrator's Manual          SHUTDOWN(8)

NAME
       shutdown - bring the system down
---cut---
but only this is visible :
---cut---

NAME
       shutdown - bring the system down

SYNOPSIS
---cut---

Can be "recovered" by scrolling down and up.

Same thing happens in gnome-terminal and xterm ( their dimension is 24x80 )
TERM=xterm


Version-Release number of selected component (if applicable):

$ rpm -qf /usr/share/man/man8/shutdown.8.gz
SysVinit-2.84-7
$ rpm -q man groff screen
man-1.5j-12
groff-1.18.1-1
screen-3.9.13-2
$ rpm -qf `which xterm`
XFree86-4.2.99.2-0.20021217.0
$ rpm -qf `which gnome-terminal`
gnome-terminal-2.1.3-2
Comment 1 David Balažic 2003-01-30 12:41:46 EST
News in phoebe2 ( 8.0.93 ) , SysVinit-2.84-7 , screen-8.9.13-2 , groff-1.1 , 
man-1.5k-2 :

man 8 shutdown displays OK in screen runnin on VT2, did not check xterm or 
gnome-terminal.
Comment 2 Tim Waugh 2003-02-06 05:38:08 EST
Please try the latest rawhide packages (groff, less).  It works for me here.
Comment 3 David Balažic 2003-02-07 05:16:55 EST
Seems OK with latest groff.
It was already OK when I posted my prev comment #1.
Comment 4 David Balažic 2003-02-12 03:51:38 EST
I have a similar problem with "man perlcc" ( on VT2 ).
Top line is missing. If I press SPACE and the 'b', it is displayed.
"man perlcc -P more" does not show the problem.

Versions :
groff-1.18.1-15
less-378-7
perl-5.8.0-83
man-1.5k-5
termcap-11.0.1-15
ncurses-5.2-29
Comment 5 Eido Inoue 2003-02-20 16:29:03 EST
fixed in latest man 1.5k and groff rawhide combo
Comment 6 David Balažic 2003-02-26 05:23:31 EST
no , I still have the same problem , using :
man-1.5k-6
groff-1.18.1-20
less-378-7
perl-5.8.0-83
Comment 7 Eido Inoue 2004-01-26 20:05:06 EST
appears to be fixed with latest groff/man running in UTF-8

Note You need to log in before you can comment on or make changes to this bug.