Bug 825738 - new biosdevname renamed em1 to em13
new biosdevname renamed em1 to em13
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: biosdevname (Show other bugs)
17
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Narendra K
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-28 06:28 EDT by Jan Vcelak
Modified: 2013-10-24 05:59 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-26 18:32:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
requested commands output (11.00 KB, application/x-gzip)
2012-05-31 08:39 EDT, Jan Vcelak
no flags Details
dmidecode output (21.49 KB, text/plain)
2013-01-28 14:17 EST, Ted
no flags Details
biosdecode output (1.79 KB, text/plain)
2013-01-28 14:17 EST, Ted
no flags Details
biosdevname output (914 bytes, text/plain)
2013-01-28 14:18 EST, Ted
no flags Details
lspci output (40.50 KB, text/plain)
2013-01-28 14:18 EST, Ted
no flags Details

  None (edit)
Description Jan Vcelak 2012-05-28 06:28:32 EDT
Description of problem:

After upgrading to F17, my em1 network interface is renamed to em13. I believe this is incorrect. When I downgrade biosdevname it works again.


Version-Release number of selected component (if applicable):
broken: biosdevname-0.4.0-1.fc17.x86_64
working: biosdevname-0.3.11-6.fc17.x86_64


How reproducible:
always


Steps to Reproduce:
1.
# rpm -q biosdevname
biosdevname-0.4.0-1.fc17.x86_64
# biosdevname -i em13
em13

2.
# yum downgrade biosdevname

3.
# rpm -q biosdevname
biosdevname-0.3.11-6.fc17.x86_64
# biosdevname -i em13
em1


Actual results:

My network device name is "em13" and therefore network does not start.


Expected results:

My network device name is "em1" as it was prior to upgrade.


Additional info:

I can provide more information if necessary.
Comment 1 Narendra K 2012-05-31 08:30:25 EDT
Hi, please provide the output from following commands -

from biosdevname-0.4.0 is installed -

biosdevname -d
dmidecode
biosdecode
lspci -xxxvvvv

And also 'biosdevname -d' from biosdevname-0.3.11.
Comment 2 Jan Vcelak 2012-05-31 08:39:17 EDT
Created attachment 588072 [details]
requested commands output

Content:

bz825738/
bz825738/biosdevname.txt
bz825738/biosdecode.txt
bz825738/lspci.txt
bz825738/biosdevname_0_3_11.txt
bz825738/dmidecode.txt
Comment 3 Narendra K 2012-06-13 11:52:53 EDT
Hi, could you please give the following biosdevname a try on your system and share the results ?

https://bugzilla.redhat.com/show_bug.cgi?id=816536#c28
Comment 4 Jan Vcelak 2012-06-15 12:39:04 EDT
Hello.

$ ./configure
...
$ make
...
$ sudo src/biosdevname -i em1
em1

So I believe the problem is gone with that version.
Comment 5 Fedora Update System 2012-07-18 09:35:54 EDT
biosdevname-0.4.1-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/biosdevname-0.4.1-1.fc17
Comment 6 Fedora Update System 2012-07-19 05:01:54 EDT
Package biosdevname-0.4.1-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing biosdevname-0.4.1-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-10778/biosdevname-0.4.1-1.fc17
then log in and leave karma (feedback).
Comment 7 Ron van Lavieren 2012-07-19 17:40:10 EDT
I installed biosdevname-0.4.1-1.fc17 from the testing repository.
Rebooted the machine with no delay.
Run the command :
 /usr/bin/time hexdump -n 1 /sys/class/net/p5p1/device/vpd
0000000 005a                                   
0000001
0.00user 0.05system 0:15.85elapsed 0%CPU (0avgtext+0avgdata 740maxresident)k
64inputs+0outputs (1major+234minor)pagefaults 0swaps

-no problems raised, so I'm happy with the new biosdevname, thanks a lot.
Comment 8 Fedora Update System 2012-07-26 18:32:23 EDT
biosdevname-0.4.1-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Ted 2013-01-28 14:16:09 EST
I recently updated to 0.4.1-1 and it broke network naming for a bunch of my systems.  p4p2 became rename4 or rename3 in most cases.
Comment 10 Ted 2013-01-28 14:17:11 EST
Created attachment 689256 [details]
dmidecode output
Comment 11 Ted 2013-01-28 14:17:48 EST
Created attachment 689258 [details]
biosdecode output
Comment 12 Ted 2013-01-28 14:18:23 EST
Created attachment 689259 [details]
biosdevname output
Comment 13 Ted 2013-01-28 14:18:45 EST
Created attachment 689261 [details]
lspci output
Comment 14 Narendra K 2013-10-24 05:59:37 EDT
(In reply to Ted from comment #9)
> I recently updated to 0.4.1-1 and it broke network naming for a bunch of my
> systems.  p4p2 became rename4 or rename3 in most cases.

Hi, this issue is fixed in the upstream tree -

Fix regression introduced by the addslot function
http://linux.dell.com/cgi-bin/gitweb/gitweb.cgi?p=biosdevname.git;a=commit;h=0bc6ce6d8da61153e7bfd1c3444ab06c0c83d0af

Could you please give the latest tree a try ?
git://linux.dell.com/biosdevname.git

Note You need to log in before you can comment on or make changes to this bug.