Bug 825866 - Anaconda malfunctions on an intentionally-broken RAID-1
Anaconda malfunctions on an intentionally-broken RAID-1
Status: CLOSED DUPLICATE of bug 189316
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-28 15:18 EDT by H. Peter Anvin
Modified: 2012-05-29 14:18 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-29 14:18:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description H. Peter Anvin 2012-05-28 15:18:41 EDT
Description of problem:

When upgrading a system with a RAID-1 disk configuration, it is extremely useful to break the mirror before the upgrade, thus providing an instant rollback mechanism.

However, Anaconda has had an amazing number of malfunctions when presented with this kind of disk configuration.

As of the Fedora 17 install media, it simply fails to see the md devices.

Version-Release number of selected component (if applicable):

Fedora 17 release DVD (version unknown)

How reproducible:

100%

Steps to Reproduce:
1. Install an older Fedora system (I am currently using Fedora 15) on a pair of mdraid RAID-1.
2. Break the mirror by disconnecting one of the drives.
3. Boot Fedora 17 from media and try to do an upgrade to Fedora 17.
  
Actual results:

md devices are simply not seen, and so F17 insists on doing a new install.


Expected results:

Offer to upgrade an existing system.
Additional info:
Comment 1 H. Peter Anvin 2012-05-28 15:23:19 EDT
Adding insult to injury, if one manually assembles and activates the mdraids in the Anaconda shell, Anaconda will "helpfully" *disabled them* on its own accord.
Comment 2 Jesse Keating 2012-05-29 14:18:22 EDT

*** This bug has been marked as a duplicate of bug 189316 ***

Note You need to log in before you can comment on or make changes to this bug.