This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 189316 - RFE: Allow degraded (one-way) RAID1 installs
RFE: Allow degraded (one-way) RAID1 installs
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
http://www.contribs.org/bugzilla/show...
:
: 825866 825867 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-18 22:17 EDT by Gordon Rowell
Modified: 2012-05-30 12:52 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-19 11:21:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Allow degraded RAID1 installs (4.80 KB, patch)
2006-04-18 22:17 EDT, Gordon Rowell
no flags Details | Diff

  None (edit)
Description Gordon Rowell 2006-04-18 22:17:19 EDT
This is an SME Server patch, pushed upstream for consideration.

We always install on RAID1, even with a single disk. This allows a smooth
transition to a mirrored configuration at a later stage.

The attached patch makes this a valid configuration and starts the RAID device
in degraded mode.
Comment 1 Gordon Rowell 2006-04-18 22:17:19 EDT
Created attachment 127965 [details]
Allow degraded RAID1 installs
Comment 2 Jeremy Katz 2006-04-19 11:21:10 EDT
We intentionally do not support degraded installs because they give a false
sense of redundancy to a user who is unaware that what they're doing is creating
a degraded array.
Comment 3 Gordon Rowell 2006-04-19 17:57:39 EDT
(In reply to comment #2)
> We intentionally do not support degraded installs because they give a false
> sense of redundancy to a user who is unaware that what they're doing is creating
> a degraded array.

Understood. Thanks.
Comment 4 Marc Bejarano 2006-08-10 15:56:37 EDT
it sounds like the purported problem is a user education one.  good
documentation and perhaps some UI work is the solution.  this would be quite a
useful feature.
Comment 5 Martin Sivák 2012-05-29 06:56:49 EDT
*** Bug 825867 has been marked as a duplicate of this bug. ***
Comment 6 Jesse Keating 2012-05-29 14:18:22 EDT
*** Bug 825866 has been marked as a duplicate of this bug. ***
Comment 7 Marc Bejarano 2012-05-30 12:52:27 EDT
hi jeremy.

care to comment on my comment 4 above?

tia

Note You need to log in before you can comment on or make changes to this bug.