This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 826027 - ipmitool segfaults in ipmi_lanplus_send_payload
ipmitool segfaults in ipmi_lanplus_send_payload
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ipmitool (Show other bugs)
6.3
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: Ales Ledvinka
qe-baseos-daemons
: Regression, ZStream
Depends On:
Blocks: 828678
  Show dependency treegraph
 
Reported: 2012-05-29 08:15 EDT by Karel Volný
Modified: 2016-09-20 00:32 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
* In a previous ipmitool update, the new options "-R" and "-N" were added to adjust the retransmission rate of outgoing IPMI requests over LAN and lanplus interfaces. Implementation of these options set a wrong default value of the retransmission timeout, and an outgoing request timed out prematurely. In addition, in some corner cases, ipmitool could terminate unexpectedly with a segmentation fault when the timeout occurred. This update fixes the default timeout value, so ipmitool without the "-N" option retransmits outgoing IPMI requests as in previous versions, and crashes no longer occur in the described scenario.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-12 08:39:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 5 Jan Safranek 2012-05-30 04:29:54 EDT
This bug has been fixed upstream, patch tracker item 3508759.

https://sourceforge.net/tracker/?func=detail&aid=3508759&group_id=95200&atid=610552

The upstream patch actually fixes something else, fixing retransmissions just as side-effect. I'll port back only the relevant part.
Comment 6 Karel Volný 2012-05-30 06:38:24 EDT
1) when using impitool delloem extensions, the new extended version crashes under some circumstances - when a connection cannot be established for some reason

for example, the command:

ipmitool -I lanplus -H $HOST -U $USERNAME -P wrongpassword delloem powermonitor


fails like this:

Error: Unable to establish IPMI v2 / RMCP+ session
Segmentation fault (core dumped)


this doesn't affect the function of the program under normal circumstances (if the connection is established)


2) with the new patch allowing to configure the timeout value, it happens that the default timeout is too low and the request fails, for example like this:

# ipmitool -I lanplus -H $HOST -U $USERNAME -P $PASSWORD sensor list
Unable to renew SDR reservation
Close Session command failed: Reservation cancelled or invalid


there is an easy workaround to specify the timeout explicitly using the new "-N" option, for example like this:

# ipmitool -I lanplus -H $HOST -U $USERNAME -P $PASSWORD -N 4 sensor list
CPU 1 Temp       | na         | degrees C  | na    | na        | na        | na        | 85.000    | 90.000    | na        
CPU 2 Temp       | na         | degrees C  | na    | na        | na        | na        | 85.000    | 90.000    | na        
...
Comment 11 Jan Safranek 2012-06-05 04:11:12 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
In the previous ipmitool update, new options '-R' and '-N' were added to adjust retransmission rate of outgoing IPMI requests over lan and lanplus interfaces. Implementation of these options set wrong default value of retransmission timeout and outgoing request timed out prematurely. In addition, in some corner cases, ipmitool could segfault when the timeout occurred. This update fixes the default timeout value and ipmitool without '-N' option retransmits outgoing IPMI requests as in previous versions.
Comment 21 errata-xmlrpc 2013-09-12 08:39:06 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1259.html

Note You need to log in before you can comment on or make changes to this bug.