Bug 828678 - ipmitool segfaults in ipmi_lanplus_send_payload
ipmitool segfaults in ipmi_lanplus_send_payload
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ipmitool (Show other bugs)
6.3
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: Jan Safranek
qe-baseos-daemons
: Regression, ZStream
Depends On: 826027
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-05 03:55 EDT by RHEL Product and Program Management
Modified: 2012-06-20 06:28 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
In the previous ipmitool update, new options '-R' and '-N' were added to adjust retransmission rate of outgoing IPMI requests over lan and lanplus interfaces. Implementation of these options set wrong default value of retransmission timeout and outgoing request timed out prematurely. In addition, in some corner cases, ipmitool could segfault when the timeout occurred. This update fixes the default timeout value and ipmitool without '-N' option retransmits outgoing IPMI requests as in previous versions.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 06:28:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description RHEL Product and Program Management 2012-06-05 03:55:49 EDT
This bug has been copied from bug #826027 and has been proposed
to be backported to 6.3 z-stream (EUS).
Comment 4 Jan Safranek 2012-06-05 04:09:57 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
In the previous ipmitool update, new options '-R' and '-N' were added to adjust retransmission rate of outgoing IPMI requests over lan and lanplus interfaces. Implementation of these options set wrong default value of retransmission timeout and outgoing request timed out prematurely. This update fixes the default timeout value and ipmitool without '-N' option retransmits outgoing IPMI requests as in previous versions.
Comment 5 Jan Safranek 2012-06-05 04:11:24 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1 @@
-In the previous ipmitool update, new options '-R' and '-N' were added to adjust retransmission rate of outgoing IPMI requests over lan and lanplus interfaces. Implementation of these options set wrong default value of retransmission timeout and outgoing request timed out prematurely. This update fixes the default timeout value and ipmitool without '-N' option retransmits outgoing IPMI requests as in previous versions.+In the previous ipmitool update, new options '-R' and '-N' were added to adjust retransmission rate of outgoing IPMI requests over lan and lanplus interfaces. Implementation of these options set wrong default value of retransmission timeout and outgoing request timed out prematurely. In addition, in some corner cases, ipmitool could segfault when the timeout occurred. This update fixes the default timeout value and ipmitool without '-N' option retransmits outgoing IPMI requests as in previous versions.
Comment 12 errata-xmlrpc 2012-06-20 06:28:33 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0999.html

Note You need to log in before you can comment on or make changes to this bug.