Bug 826105 - backend [multiple domains]: trying to move several disks when one of the disks resides on domian in maintenance will give wrong error
backend [multiple domains]: trying to move several disks when one of the disk...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
x86_64 Linux
high Severity high
: ---
: 3.1.0
Assigned To: mkublin
vvyazmin@redhat.com
storage
:
Depends On: 833339
Blocks: 563304 830872 831988 835348 835349 835724
  Show dependency treegraph
 
Reported: 2012-05-29 11:37 EDT by Dafna Ron
Modified: 2016-02-10 11:29 EST (History)
9 users (show)

See Also:
Fixed In Version: SI6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 14:59:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log (36.11 KB, application/x-xz)
2012-05-29 11:37 EDT, Dafna Ron
no flags Details

  None (edit)
Description Dafna Ron 2012-05-29 11:37:18 EDT
Created attachment 587440 [details]
log

Description of problem:

trying to move multiple disks that resides on multiple domains when one of the disks resides on a domain which is in maintenance will show wrong error:

Error: Cannot move Virtual Machine Disk. Same action in progress.

engine: 

2012-05-26 18:25:40,751 WARN  [org.ovirt.engine.core.bll.MoveOrCopyDiskCommand] (pool-10-thread-46) CanDoAction of action MoveOrCopyDisk failed. Reasons:VAR__ACTION__MOVE,VAR__TYPE__VM_DISK,ACTION_TYPE_FAILED_OBJECT_LOCKED


Version-Release number of selected component (if applicable):

si4

How reproducible:

100%

Steps to Reproduce:
1. create 3 domains
2. create a vm with two disks - each disk should reside on a different domain
3. put the one of the domain in maintenance -> try to move the 2 disks to the 3ed domain 
  
Actual results:

 we fail with the following error: 

Error: Cannot move Virtual Machine Disk. Same action in progress.


Expected results:

error should be that the domain status is illigual and specify the disk name so we know which one fialed. 

Additional info: full log
Comment 1 mkublin 2012-06-05 08:00:41 EDT
Same problem as at bug: https://bugzilla.redhat.com/show_bug.cgi?id=826059, lock was not relased a fix should solve a problem

http://gerrit.ovirt.org/#change,4671
Comment 2 vvyazmin@redhat.com 2012-06-21 08:54:23 EDT
Can't verified, because it blocked by another bug: 833339
Comment 3 vvyazmin@redhat.com 2012-07-19 08:02:37 EDT
Verified on RHEVM 3.1 - SI10

RHEV-M: rhevm-3.1.0-6.el6ev.noarch
VDSM: vdsm-4.9.6-21.0.el6_3.x86_64
LIBVIRT: libvirt-0.9.10-21.el6_3.1.x86_64
QEMU & KVM: qemu-kvm-rhev-0.12.1.2-2.295.el6.x86_64

Note You need to log in before you can comment on or make changes to this bug.