Bug 833339 - webadmin: move disk dialogue will not close after getting CanDoAction from backend when trying to move a disk that already started move
webadmin: move disk dialogue will not close after getting CanDoAction from ba...
Status: CLOSED DUPLICATE of bug 832794
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
x86_64 Linux
high Severity medium
: ---
: 3.1.0
Assigned To: Asaf Shakarchi
Dafna Ron
storage
:
Depends On:
Blocks: 826105 828110
  Show dependency treegraph
 
Reported: 2012-06-19 05:13 EDT by Dafna Ron
Modified: 2016-02-10 12:05 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-04 12:58:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen shot and log (76.11 KB, application/x-gzip)
2012-06-19 05:13 EDT, Dafna Ron
no flags Details
local logs and screen shot (85.52 KB, application/x-gzip)
2012-06-19 05:52 EDT, Dafna Ron
no flags Details

  None (edit)
Description Dafna Ron 2012-06-19 05:13:41 EDT
Created attachment 592883 [details]
screen shot and log

Description of problem:

moving a disk will not lock the disk right away (specially when we have several actions for different disks). 
I can try to move the disk twice to different domains. 
the action will fail in backend with CanDoAction but UI dialogue will remain opened with sandclock and we have to reload the UI to continue working

Version-Release number of selected component (if applicable):

si6

How reproducible:

100%

Steps to Reproduce:
1. move disk
2. before its locked move it again
3.
  
Actual results:

backend log shows CanDoAction but UI's Move Disk dialogue remains open with sandclock

Expected results:

we should either prevent the move in the first place or report the CanDoAction

Additional info: screen shot + log


2012-06-19 12:04:24,328 WARN  [org.ovirt.engine.core.bll.MoveOrCopyDiskCommand] (ajp--0.0.0.0-8009-9) CanDoAction of action MoveOrCopyDisk failed. Reasons:VAR__ACTION__MOVE,VAR__TYPE__VM_DISK,ACTION_TYPE_FAILED_OBJECT_LOCKED
Comment 1 Dafna Ron 2012-06-19 05:49:03 EDT
I have similar issue when I failed configure of local storage. 
the dialogue remains open even though the operation failed.
Comment 2 Dafna Ron 2012-06-19 05:52:53 EDT
Created attachment 592890 [details]
local logs and screen shot
Comment 3 Yaniv Kaul 2012-06-19 07:53:53 EDT
Similar / duplicate to https://bugzilla.redhat.com/show_bug.cgi?id=832794#c1 - a CanDoAction failure is not propagated.
Comment 4 Dafna Ron 2012-06-19 11:27:03 EDT
same thing for Move when SD is not available.
Comment 5 Asaf Shakarchi 2012-07-04 12:58:59 EDT
This is because a constant string is missing in UI which is exactly the string missing in BZ #832794, gerrit patch: 
http://gerrit.ovirt.org/#/c/5893/

*** This bug has been marked as a duplicate of bug 832794 ***

Note You need to log in before you can comment on or make changes to this bug.