Bug 826113 - New Image : Upload and URL option does not show any error message when accounts are not mapped to the cloud in which images are being launched
New Image : Upload and URL option does not show any error message when accoun...
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Jozef Zigmund
Rehana
: Triaged, ZStream
Depends On: 806846
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-29 11:54 EDT by Chris Pelland
Modified: 2012-12-04 10:09 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
There was no error message to alert the user to add a provider account before building an image. This could cause a user to think that image options were broken. This update provides an alert message to remind users to add a provider account prior to building an image.
Story Points: ---
Clone Of: 806846
Environment:
Last Closed: 2012-12-04 10:09:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Tzu-Mainn Chen 2012-05-29 13:42:21 EDT
Pushed to 1.0.1:

commit 8552fa5732edad7f7b0ae059eb2ba7368f992aeb
BZ 806846 Disabled submit_tag in images#new views when no provider are enabl
    
    Conflicts:
    
        src/app/views/images/import.html.haml
        src/app/views/images/new.html.haml

commit b441ca139c167ef67a9cfa2b692af80b128a34b1
BZ 806846 ImageController: removed duplicate code, fixed flash displaying
    
    Conflicts:
    
        src/app/controllers/images_controller.rb
        src/config/locales/en.yml
Comment 2 Matt Wagner 2012-09-13 18:12:12 EDT
I see this now on 1.1:

commit dec27f231cacb1ba11e2ddb6f9a2bd77d48c87e4
Author: Jozef Zigmund <jzigmund@redhat.com>
Date:   Thu May 24 17:37:13 2012 +0200

    BZ 806846 Disabled submit_tag in images#new views when no provider are enabled

commit 144afb2834b7589e6a1860b846c2ee5c6913eb93
Author: Jozef Zigmund <jzigmund@redhat.com>
Date:   Thu May 24 17:03:09 2012 +0200

    BZ 806846 ImageController: removed duplicate code, fixed flash displaying
Comment 4 Aziza Karol 2012-09-21 07:07:31 EDT
"Images cannot be built. There are no enabled Cloud Resource Provider Accounts associated with this Cloud" is displayed when trying to build and image when accounts are not mapped to the cloud.

verified:
rpm -qa | grep aeolus
aeolus-conductor-daemons-0.13.8-1.el6cf.noarch
rubygem-aeolus-cli-0.7.1-1.el6cf.noarch
aeolus-configure-2.8.6-1.el6cf.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-conductor-0.13.8-1.el6cf.noarch
aeolus-conductor-doc-0.13.8-1.el6cf.noarch
aeolus-all-0.13.8-1.el6cf.noarch
Comment 6 errata-xmlrpc 2012-12-04 10:09:46 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.