Bug 826139 - docbook2man escapes double-quotes in headings incorrectly
docbook2man escapes double-quotes in headings incorrectly
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: docbook-utils (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 826145
  Show dependency treegraph
 
Reported: 2012-05-29 13:12 EDT by Jan Vcelak
Modified: 2013-03-03 20:30 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-30 08:26:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
source files for reproduction (10.89 KB, application/x-gzip)
2012-05-29 13:12 EDT, Jan Vcelak
no flags Details
proposed patch (228 bytes, patch)
2012-05-29 13:15 EDT, Jan Vcelak
no flags Details | Diff

  None (edit)
Description Jan Vcelak 2012-05-29 13:12:35 EDT
Created attachment 587463 [details]
source files for reproduction

Description of problem:

If the title in the input SGML document contains double-quote character, it is escaped incorrectly and the output manual page is damaged.

Currently, the docbook2man-spec.pl script uses zero-width-character \& which is added before the double quote character. The purpose of zero-width-character is completely different [1]. Double-quote character in macro argument has to be replaced by double quote glyph \(dq or has to be doubled [2].

In case of docbook2man-spec.pl, the second approach is better, otherwise the order of the operations would have to be changed. The string is being converted to uppercase after the escaping, which would break the double quote glyph.


[1] http://www.gnu.org/software/groff/manual/html_node/Ligatures-and-Kerning.html
[2] http://www.gnu.org/software/groff/manual/html_node/Request-and-Macro-Arguments.html


Version-Release number of selected component (if applicable):
docbook-utils-0.6.14-30.fc17.noarch
(and probably all others)


How reproducible:
Take a look at "man 5 fonts-conf", which is damaged. I'm attaching the source SGML files to reproduce and validate the fix.


Steps to Reproduce:
1. decompress the archive
2. run: docbook2man fontconfig-user.sgml
3. run: man ./fonts-conf.5 
  
Actual results:

...
<INCLUDE IGNORE_MISSING= NO">"
...


Expected results:

...
<INCLUDE IGNORE_MISSING="NO">
...


Additional info:

This is not a bug in groff:
https://bugzilla.redhat.com/show_bug.cgi?id=797005
Comment 1 Jan Vcelak 2012-05-29 13:15:08 EDT
Created attachment 587464 [details]
proposed patch
Comment 2 Ondrej Vasik 2012-05-30 02:04:02 EDT
Thanks for the report and patch, Honza.
Comment 3 Ondrej Vasik 2012-05-30 08:26:26 EDT
Should be fixed by http://lists.fedoraproject.org/pipermail/scm-commits/2012-May/787200.html - docbook-utils-0.6.14-31.fc18 -> closing RAWHIDE.
Comment 4 Akira TAGOH 2012-05-31 05:49:11 EDT
Any plans to backport the fix for f17?
Comment 5 Ondrej Vasik 2012-06-01 04:31:58 EDT
I'll do an update for f16/f17 today...
Comment 6 Fedora Update System 2012-06-01 05:01:10 EDT
docbook-utils-0.6.14-30.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/docbook-utils-0.6.14-30.fc16
Comment 7 Fedora Update System 2012-06-01 05:04:45 EDT
docbook-utils-0.6.14-31.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/docbook-utils-0.6.14-31.fc17
Comment 8 Fedora Update System 2012-06-19 10:56:05 EDT
docbook-utils-0.6.14-30.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2012-06-19 10:56:38 EDT
docbook-utils-0.6.14-31.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.