Bug 826463 - Gluster - Backend: Exception on entering bad text in Volume Options
Gluster - Backend: Exception on entering bad text in Volume Options
Status: CLOSED DUPLICATE of bug 823565
Product: oVirt
Classification: Community
Component: ovirt-engine-core (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Bala.FA
Haim
gluster
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-30 05:14 EDT by Daniel Paikov
Modified: 2015-11-22 21:57 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-11 06:11:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine.log (32.48 KB, application/x-compressed-tar)
2012-05-30 05:14 EDT, Daniel Paikov
no flags Details
vdsm.log (274.84 KB, application/x-compressed-tar)
2012-05-31 05:28 EDT, Daniel Paikov
no flags Details

  None (edit)
Description Daniel Paikov 2012-05-30 05:14:59 EDT
Created attachment 587654 [details]
engine.log

Entering bad text in the Volume Options produces an exception. In my example I entered "xxx" in "nfs.disable", which only accepts values of "on" and "off".
Comment 1 Bala.FA 2012-05-30 21:59:21 EDT

Do you mean UI allows to enter other than  on/off?
Do you see exception similar to
https://bugzilla.redhat.com/show_bug.cgi?id=823565?
Can you attach respective vdsm log?
Comment 2 Daniel Paikov 2012-05-31 05:28:20 EDT
Yes, the UI allows entering any text in the textbox.

Attaching vdsm.log (from a new reproduction of the same flow).
Comment 3 Daniel Paikov 2012-05-31 05:28:49 EDT
Created attachment 588012 [details]
vdsm.log
Comment 4 Shireesh 2012-06-11 06:11:59 EDT
UI does not enforce validations on the values of options. If you enter invalid values for options, glusterfs will throw an error (seen in the vdsm.log attached by you). This error should be displayed on the UI as well.

There was a problem in vdsm (823565) when you raised this bug, because of which it used to crash and proper error didn't reach the UI. This is fixed now, and you should see the error returned by glusterfs on the UI as well.

Closing the bug, marking it as duplicate of 823565.

*** This bug has been marked as a duplicate of bug 823565 ***

Note You need to log in before you can comment on or make changes to this bug.