Bug 826465 - Gluster - Backend: Unpredictable results when setting nfs.disable to on
Gluster - Backend: Unpredictable results when setting nfs.disable to on
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-engine-core (Show other bugs)
unspecified
Unspecified Unspecified
medium Severity medium
: ---
: 3.2
Assigned To: Raghavendra Bhat
gluster
:
: 826942 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-30 05:24 EDT by Daniel Paikov
Modified: 2013-02-15 01:47 EST (History)
8 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0qa4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-15 01:47:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine.log (33.28 KB, application/x-compressed-tar)
2012-05-30 05:24 EDT, Daniel Paikov
no flags Details
vdsm.log (963.64 KB, application/x-compressed-tar)
2012-05-31 05:31 EDT, Daniel Paikov
no flags Details

  None (edit)
Description Daniel Paikov 2012-05-30 05:24:08 EDT
Created attachment 587656 [details]
engine.log

Volumes -> select volume -> Volume Options -> nfs.disable (by default set to "off") -> Edit -> change "off" to "on" -> OK -> the result is that nfs.disable remains "off" but a new key is added with the name "nfs.enable-ino32" and with the value "on".
Comment 1 Bala.FA 2012-05-30 21:58:53 EDT
I suspect that it could be a gluster bug.
1, Can yoy send me 'gluster --version' output of the host?
2. Can you attach respective vdsm log?
Comment 2 Daniel Paikov 2012-05-31 05:31:34 EDT
Created attachment 588014 [details]
vdsm.log

Attaching vdsm.log (from a new run of the same flow).

Gluster version:
glusterfs 3.3.0qa41 built on May 16 2012 23:00:40
Comment 3 Shireesh 2012-06-11 06:16:49 EDT
This is happening because the "gluster volume set help-xml" command is not returning "nfs.disable" as one of the options. Assigning to Vijay for resolution.
Comment 4 Shireesh 2012-06-11 06:19:41 EDT
*** Bug 826942 has been marked as a duplicate of this bug. ***
Comment 5 Raghavendra Bhat 2012-12-04 05:04:23 EST
seems to me as duplicate of bug 828027. That bug is closed as fixed with below comment:

The patch has been accepted into both master & release-3.3 branches upstream.
The respective commits are,
4b09879 (glusterd: nfs.disable fix for "volume set help") for master, reviewed
at http://review.gluster.com/3509
948b9a5 (glusterd: nfs.disable fix for "volume set help") for release-3.3,
reviewed at http://review.gluster.org/3881
----

also checked on 3.4.0qa4, and below is the output

[root@thinkpad raghu]# gluster volume set help-xml | xmllint --format - | grep nfs.disable
    <name>nfs.disable</name>

Note You need to log in before you can comment on or make changes to this bug.