Bug 826471 - The old rhc command such as "rhc-create-app" and "rhc-create-domain" don't create the missing directory like ".openshift".
The old rhc command such as "rhc-create-app" and "rhc-create-domain" don't cr...
Status: CLOSED DUPLICATE of bug 826472
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: Clayton Coleman
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-30 05:46 EDT by yquan
Modified: 2015-05-14 21:56 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-30 16:38:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description yquan 2012-05-30 05:46:09 EDT
Description of problem:
The old command such as "rhc-create-app" and "rhc-create-domain" don't create the missing directory like ".openshift".

Version-Release number of selected component (if applicable):
rhc-0.93.15-1.el6_2.noarch

How reproducible:
always.

Steps to Reproduce:
1.Use command "rhc setup" and input the information.
2.Remove the sshkey and .openshift directory.
3.use command"rhc-create-app" and "rhc-create-domain"
  
Actual results:
It doesn't recreate the .openshift directory.

Expected results:
It should like the command "rhc domain create" and "rhc app create",will have "rhc setup" step.

Additional info:
Comment 1 Rob Millner 2012-05-30 12:49:56 EDT
I believe the underlying problem is that ~/.openshift/express.conf is now required, commands will fail if it doesn't exist.
Comment 2 Fabiano Franz 2012-05-30 16:38:39 EDT

*** This bug has been marked as a duplicate of bug 826472 ***

Note You need to log in before you can comment on or make changes to this bug.