This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 826472 - It will return exception when use command "rhc-create-domain" after delete the .openshift directory.
It will return exception when use command "rhc-create-domain" after delete th...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
libra bugs
: Triaged
: 826471 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-30 05:47 EDT by yquan
Modified: 2015-05-14 21:56 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-25 14:26:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description yquan 2012-05-30 05:47:37 EDT
Description of problem:
It will return exception when use command "rhc-create-domain" after delete the .openshift directory.

Version-Release number of selected component (if applicable):
rhc-0.93.15-1.el6_2.noarch

How reproducible:
always.

Steps to Reproduce:
1.use command "rhc setup" and input your information. 
2.remove the directory ~/.openshift.
3.use old command "rhc-create-domain -n domaintest0003"   #the user must don't have any domain.
  
Actual results:
It will return exception.


[root@localhost home]# rhc-create-domain -n domaintest0003 -l yquan@redhat.com
Password: *********

OpenShift key found at /root/.ssh/id_rsa.  Reusing...
/usr/lib/ruby/gems/1.8/gems/rhc-0.93.15/lib/rhc-common.rb:1027:in `initialize': No such file or directory - /root/.openshift/express.conf (Errno::ENOENT)
	from /usr/lib/ruby/gems/1.8/gems/rhc-0.93.15/lib/rhc-common.rb:1027:in `open'
	from /usr/lib/ruby/gems/1.8/gems/rhc-0.93.15/lib/rhc-common.rb:1027:in `add_rhlogin_config'
	from /usr/lib/ruby/gems/1.8/gems/rhc-0.93.15/bin/rhc-create-domain:147
	from /usr/local/bin/rhc-create-domain:19:in `load'
	from /usr/local/bin/rhc-create-domain:19



Expected results:
It should create domain successfully.
And should also have "rhc setup" wizard steps.

Additional info:
Comment 1 John (J5) Palmieri 2012-05-30 16:33:19 EDT
Unfortunately the wizard removed the config generation code but I am punting this so it doesn't hold up the release since rhc-create-domain is deprecated for rhc create-domain.  Will fix early next sprint.
Comment 2 John (J5) Palmieri 2012-05-30 16:33:54 EDT
rhc domain create that is
Comment 3 Fabiano Franz 2012-05-30 16:38:39 EDT
*** Bug 826471 has been marked as a duplicate of this bug. ***
Comment 4 Jianwei Hou 2012-06-20 08:33:44 EDT
fixed version rhc-0.94.7-1.el6_3.noarch

Note You need to log in before you can comment on or make changes to this bug.