Bug 826493 - Group without members with unknown status appears in every availabilty search result
Group without members with unknown status appears in every availabilty search...
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: UI (Show other bugs)
JON 3.1.0
Unspecified Unspecified
unspecified Severity medium
: ---
: JON 3.1.1
Assigned To: Mike Thompson
Mike Foley
:
Depends On: 850229
Blocks: 845389
  Show dependency treegraph
 
Reported: 2012-05-30 07:02 EDT by Sunil Kondkar
Modified: 2013-09-11 07:03 EDT (History)
1 user (show)

See Also:
Fixed In Version: jon3.1.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 845389 (view as bug list)
Environment:
Last Closed: 2013-09-11 07:03:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot (85.20 KB, image/png)
2012-05-30 07:02 EDT, Sunil Kondkar
no flags Details

  None (edit)
Description Sunil Kondkar 2012-05-30 07:02:08 EDT
Description of problem:

Created a group of resources and then removed all member resources from the group. when trying the group search criteria for availability=up and others such as availability=disabled and availability=down, the search result display the group without members having unknown status in group list view.

Please refer the attached screenshot.


Version-Release number of selected component (if applicable):

Version: 3.1.0.CR1 Build Number: 4bc4270:1b85993

How reproducible:

Always

Steps to Reproduce:
1. Create a compatible or mixed group of resources

2. Remove all members from the group (Groups Inventory tab->Update membershitp button->Unassign all member resources->Save)

3. Observe the group has unknown status.

4. Navigate to Inventory->Groups->All groups.

5. Enter search criteria as availability=up in search bar and press 'Enter'.

6. The search results display the group with unknown status in group list view.

7. Repeat the search criteria as availability=down, availability=disabled.

8. The search results display the group with unknown status in group list view.
  
Actual results:

The group without members and with unknown status appear in availability search criterias for up, down and disabled.

Expected results:

The group without members and with unknown status should not appear in availability search criterias for up, down and disabled.

Additional info:
Comment 1 Sunil Kondkar 2012-05-30 07:02:38 EDT
Created attachment 587682 [details]
Screenshot
Comment 2 Charles Crouch 2012-06-11 10:51:01 EDT
As per 6/4/12 triage, target for jon311
Comment 3 Mike Thompson 2012-08-08 15:45:22 EDT
jon3.1.1 commit id: 2bf05ba

Eliminated the superfluous empty groups as unknown status in availability searches.

Cherry picked from RHQ Master commit id: 1555257


RHQ BZ: https://bugzilla.redhat.com/show_bug.cgi?id=845389
Comment 4 John Sanda 2012-08-13 22:16:44 EDT
Moving to ON_QA since JON 3.1.1 ER2 build is availble - https://brewweb.devel.redhat.com/buildinfo?buildID=228250
Comment 5 John Sanda 2012-08-20 11:59:39 EDT
Moving back to ON_DEV because of bug 848893 which was introduced as part of the work for this bug.
Comment 6 Mike Thompson 2012-08-20 17:40:49 EDT
jon3.1.x commit id: 30359bc

Talked with jsanda and agreed it should be in here although [BZ 848893] sits on top of this one and corrects additional functionality.
Comment 7 Sunil Kondkar 2012-08-22 03:43:48 EDT
Verified on Version: 3.1.1.ER3 Build Number: 37108ca:67c6de8

Note You need to log in before you can comment on or make changes to this bug.