Bug 826599 - [RHEVM] [backend] [Required Networks] inappropriate error message when VM fails to start because of missing optional network
[RHEVM] [backend] [Required Networks] inappropriate error message when VM fai...
Status: CLOSED DUPLICATE of bug 841586
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: lpeer
Martin Pavlik
network
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-30 11:07 EDT by Martin Pavlik
Modified: 2016-02-10 14:55 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-19 08:22:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vdsm.log + engine.log (26.19 KB, application/x-gzip)
2012-05-30 11:07 EDT, Martin Pavlik
no flags Details
screenshot of error message (163.99 KB, image/png)
2012-05-30 11:07 EDT, Martin Pavlik
no flags Details

  None (edit)
Description Martin Pavlik 2012-05-30 11:07:24 EDT
Created attachment 587764 [details]
vdsm.log + engine.log

Description of problem:
when user tries to start VM on host which is missing optional network following error message appears:
VM winXP is down. Exit message: Cannot get interface MTU on 'nonRequired': No such device.

From this message it is not very cleat what is the real problem. That VM which is started has NIC/NICs attached to non-required network which is not attched to host.


Version-Release number of selected component (if applicable):
oVirt Enterprise Virtualization Engine Manager Version: 3.1.0_0001-11.el6ev 

How reproducible:
100%

Steps to Reproduce:
1. Create logcial network and attach to cluster
2. configure new network as required=false
3. create VM, attach new network to VM, try to start VM


Actual results:
VM winXP is down. Exit message: Cannot get interface MTU on 'nonRequired': No such device.

Expected results:
Message which describes what the problem is more precisely, e.g.
VM $VM is failed to start. VM $VM has attached network $network which is not attached to host $host.

Additional info:
error which is displayed in events comes from libvirt

Thread-2418::ERROR::2012-05-30 13:53:24,290::vm::601::vm.Vm:_startUnderlyingVm) vmId=`e81eb68f-e3d6-471f-a003-c89118e97457`::The vm start process failed
Traceback (most recent call last):
  File "/usr/share/vdsm/vm.py", line 567, in _startUnderlyingVm
    self._run()
  File "/usr/share/vdsm/libvirtvm.py", line 1365, in _run
    self._connection.createXML(domxml, flags),
  File "/usr/lib/python2.6/site-packages/vdsm/libvirtconnection.py", line 82, in wrapper
    ret = f(*args, **kwargs)
  File "/usr/lib64/python2.6/site-packages/libvirt.py", line 2486, in createXML
    if ret is None:raise libvirtError('virDomainCreateXML() failed', conn=self)
libvirtError: Cannot get interface MTU on 'nonRequired': No such device
Comment 1 Martin Pavlik 2012-05-30 11:07:46 EDT
Created attachment 587765 [details]
screenshot of error message
Comment 2 Omer Frenkel 2012-08-19 08:22:53 EDT

*** This bug has been marked as a duplicate of bug 841586 ***

Note You need to log in before you can comment on or make changes to this bug.