Bug 841586 - [TEXT] - error message not good enough when running VM on host without optional network
[TEXT] - error message not good enough when running VM on host without option...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Omer Frenkel
GenadiC
Network
:
: 826599 847987 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-19 09:44 EDT by GenadiC
Modified: 2015-10-27 19:58 EDT (History)
11 users (show)

See Also:
Fixed In Version: si15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description GenadiC 2012-07-19 09:44:52 EDT
Description of problem:

Running VM fails without any popup message when creating Network on the Cluster without attaching it to host, but attaching it to specific NIC on the VM

How reproducible:
Always

Steps to Reproduce:
1. Create Non-required Network and attach it to the Cluster (working with one host)
2. Don't attach it to host
3. Configure that Network on specific NIC of the VM
4. Try to run VM
  
Actual results:

No error message is displayed and VM doesn't start running

Expected results:
Pop up message should appear saying that this Network is not configured on the specific host 

Additional info:
Comment 3 lpeer 2012-07-29 04:03:20 EDT
Is this solved in si12 followed by the fix to BZ827014?
Comment 4 GenadiC 2012-07-30 09:04:28 EDT
Although now we get an error pop up message, but it is not a clear one.
The message says: "Error while executing action Run VM once: Internal oVirt Engine Error" and this message doesn't explain the problem of failure
Comment 5 lpeer 2012-07-30 09:12:42 EDT
(
Comment 7 meital avital 2012-08-14 11:55:59 EDT
*** Bug 847987 has been marked as a duplicate of this bug. ***
Comment 8 lpeer 2012-08-15 03:30:30 EDT
http://gerrit.ovirt.org/#/c/7130/
Comment 11 Omer Frenkel 2012-08-19 08:22:53 EDT
*** Bug 826599 has been marked as a duplicate of this bug. ***
Comment 12 GenadiC 2012-08-22 09:30:00 EDT
Verified in SI15

Note You need to log in before you can comment on or make changes to this bug.